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MultiTrans 7 Patch 7.0.22027.1 – 7.0.22119.1 
 

 

New Features 
1. (55218, 55219, 55228, 55233) Productivity Templates are available to create standard capacities 

for different unit types, for example, the rate at which exact matches or new segments can be 
processed. These templates can be applied to Providers rather than setting the capacities at the 
Provider level.   

a. Productivity Templates can be (55222) created, (55223) edited, (55225) copied, and 
(55224) deleted. 

b. (55229) Productivity Templates can be applied to a Provider, keeping that Provider’s 
existing capacities and abilities intact. 

c. (55230) When a Productivity Template is modified, all capacities linked to that template 
for all Providers are modified automatically. 

d. (55226) Existing Productivity Templates can be associated to a Provider via the Provider 
CSV Import. 

e. (55227) Existing Productivity Templates can be associated to a Provider via the Provider 
XML Import. 

2. (73661) On the Scheduling Timeline, upon hovering over a task, the date and time that the task 
was assigned to the Provider as well as the Project Delivery date and time are displayed. 

3. (73662) Projects can be opened directly from the Scheduling Timeline. 

4. (73654) Negative invoice values can be displayed through the Customer Portal. This applies to 
invoices created through MultiTrans, manually uploaded invoices or invoices created through 
the custom Template Service.  

a. In the Invoices section of the Customer Portal Dashboard, the invoice total value is 
deducted from the Total Due or Total Paid as applicable. 

b. On the Invoices List section of the Customer Portal Invoices tab, the invoice Total can 
display as negative. 

c. On the Invoices List section of the Customer Portal Invoices tab, the CSV generated by 
clicking Download All displays the Total value as negative from invoices where the total 
is negative. 

5. (73656) Negative invoice values can be exported through CSV Invoice Templates. 

 

Program Updates 
6. (73941) The log4j library has been updated to version 2.17.1. 

7. (63575) The commons-fileupload library has been updated to version 1.4. 
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8. (73637) The Jersey library has been updated to version 2.35. 

9. (74933) The xerces library has been updated to version 2.12.2. 

10. (74932) The h2 library has been updated to version 2.1.210. 

11. (76184) The Spring Framework has been updated to version 5.3.18. 

12. (73769) Hyperlinks display correctly on the Login Page after being edited, and open on a new 
browser tab when clicked. 

13. (73609) Offline review files can be retrieved from the Customer Portal. 

14. (65146) The setting to Automatically Postpone Target Date for Projects Waiting for Approval or 
Quote does not overwrite user-uploaded PDF quotes. 

15. (74292) The pagination for Customer Invoices in the Project Manager Portal has been corrected. 

16. (75691) No extraneous error messages display when creating a customer invoice from the 
Project Manager Portal. 

17. (73738) Customer invoices can be deleted before they are completely created. 

18. (76005) Additional error handling has been added to the customer invoice upload. 

19. (73725) Projects by Status can be retrieved clicking the links on the Project Manager Portal 
Dashboard. 

20. (74379) The Project Status filter returns results in the Project Manager Portal Task List. 

21. (74944) Extraneous error messages do not appear when selecting the Active Workflow Tasks 
from the Projects List in the Project Manager Portal. 

22. (74022, 75585, 75588, 75589) The Settings > Enterprise > Scheduling options are described 
more accurately. 

23. (73932, 74665) Proper error handling has been added for when an invalid file type is added as a 
logo in the Settings > Invoice Configuration. 

24. (76531) Administrators and Project Managers are returned to the Project Template window 
after deleting an unnecessary project template. 

25. (75523) Tasks from parallel static workflows display correctly in the Scheduling Timeline. 

26. (75495) When scheduling is configured to be via Pay(h), the Scheduling Timeline updates when 
the Pay(h) is updated manually. 

27. (69842) The scheduling window opened via the Provider Search within a project closes when the 
top right-hand X is clicked. 

28. (69948) The <%TaskCost%> variable appears in the French Task to be approved notification 
template. 

29. (74293) Contents of notification templates display without HTML encoding. 

30. (74059) The File Downloads report available through the new SSRS-based reporting module 
downloads in all selected languages. 
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31. (75141) The MultiTrans Savings report available through the new SSRS-based reporting module 
generates correctly. 

32. (74564) The Invoices Detailed report available through the new SSRS-based reporting module 
generates correctly. 

33. (69995) Word documents with hidden text are analysed correctly. 

34. (68975) Word documents with author information are analysed correctly. 

35. (73636) Web Editor documents can be saved after removing tags from auto-propagated 
segments. 

36. (76436) The Web Editor can search and replace multiple instances of the same text within a 
single segment. 

37. (76457, 76558) The Web Editor can search and replace all instances of searched text in a large 
document. 

38. (76142) The Web Editor can find formatted text. 

39. (68741) <Format> tags are preserved upon saving Web Editor documents. 

40. (76055) Tracked change version numbers from the Web Editor have been corrected. 

41. (76596) Tags cannot be mismatched when repeatedly splitting and merging segments containing 
opening and closing tags in the XLIFF Editor. 

42. (76626) The XLIFF Editor correctly exports documents with segments that have been repeatedly 
split then merged. 

43. (75182, 76578) Additional safety checks have been added to ensure Word documents with 
empty text nodes can be exported from XLIFF. 

44. (73837) XLIFF files with modified hyperlinks can be previewed and exported. 

45. (76390) The Translation Agent replaces format tags in the XLIFF Editor. 

46. (76336) The option to add tags appears in the contextual (right-click) menu of the XLIFF Editor. 

47. (74263, 76569) All content and tags are correctly transferred when using the Review in Word 
and the Import Word Review from the XLIFF Editor. 

48. (76387) The REST API updateTask method updates the document information. 

49. (76354) The REST API updateTaskWithPackage allows the update of packages containing *.MIF 
files. 

50. (75995) SDLXLIFF files with empty <ept /> nodes can be correctly returned to MultiTrans using 
the Trados Studio connector. 

51. (76509) Administrators and Project Managers are prompted to add a culture code when adding 
a new language in MultiTrans Flow. 

52. (74323, 74330) Feedback messaging when importing Provider and Customer XML or CSV has 
improved. 
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53. (74578) Users created through MultiTrans Flow with the requirement to change their password 
are prompted to do so at their first login, rather than their second login. 

54. (74580) Provider password changes are made in My Flow without extraneous error messages. 

55. (75574) The time zone options in My Flow are properly ordered. 

56. (66401) Extra workdone units can be added when updating a task from the Provider Portal. 

57. (70045) The Auto-Align Scheduler password is encrypted in JobsOptions.xml. 

58. (73382, 73384, 73385) Additional validation has been added to prevent potential blind SQL 
injections in the List Administration area. 

59. (75598, 75599) Additional data filtering has been added to prevent potential cross-site scripting 
(XSS) vulnerabilities in the Invoices module. 

60. (73381) Additional data filtering has been added to prevent potential cross-site scripting (XSS) 
vulnerabilities in the Projects module. 

61. (76496) Additional data filtering has been added to prevent potential cross-site scripting (XSS) in 
Project Templates. 

62. (73354) Additional data filtering has been added to prevent potential cross-site scripting (XSS) 
vulnerabilities in the Project Manager Dashboard. 

63. (73373, 73375) Additional data filtering has been added to prevent potential cross-site scripting 
(XSS) vulnerabilities with Customer Teams. 

64. (73525) Additional data filtering has been added to prevent potential cross-site scripting (XSS) 
vulnerabilities related to Provider documents. 

65. (73900) Authorization cannot be bypassed to intercept a Provider’s Invoice export. 

66. (73919) Authorization cannot be bypassed to intercept a Provider’s Timesheet export. 

67. (73929) Authorization cannot be bypassed to intercept Provider documents. 

68. (73921) Authorization cannot be bypassed to intercept Delivery Agreements. 

69. (74362) A user attacked via Persistent XSS can continue to load the Project Manager Portal, 
access rights permitting. 

70. (73364, 74684) The encrypted password in the MultiTrans Settings is no longer returned when 
debugging the HTML of that page. 

71. (75468) The CORS filter has been restricted to enhance security within MultiTrans Flow. 

72. (73896) The contract logos are restricted to image files. 

73. (73672, 73673, 73684, 73705, 73712, 73719, 73721, 73723) Potential cross-site scripting (XSS) 
vulnerabilities identified via static code scans have been eliminated. 

74. (63406, 73666) Potential SQL injection vulnerabilities identified via static code scans have been 
eliminated. 

75. (69994) WCAG – All drop-down lists in the Project tab for individual projects in the Project 
Manager Portal are keyboard accessible. 
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76. (63766, 63792, 63804, 63805, 63813, 63824, 63839, 63865, 63866, 63875) WCAG – alt 
attributes have been added to spacer images, so they will be ignored by a screen reader. 

77. (63718, 63730, 63777, 63793, 63806, 63814, 63843, 63861, 63867) WCAG – The 
role=’presentation’ has been added to a variety of tables in the Project Manager Portal. 

78. (63778) WCAG – Form labels are associated to form controls in the Project tab for individual 
projects in the Project Manager Portal. 

79. (63788) WCAG – alt text has been added to icons in the Project tab for individual projects in the 
Project Manager Portal. 

80. (63790) WCAG – The description of asterisks denoting mandatory fields has been moved to the 
top of the page. 

81. (63791) WCAG – alt text has been added to icons on the Documents tab for individual projects 
in the Project Manager Portal. 

82. (63794) WCAG – The expand/collapse functionality for each section in the Documents tab for 
individual projects in the Project Manager Portal is keyboard accessible. 

83. (63797, 63835) WCAG – Heading levels have been modified for better navigation in the 
Documents and Contracts tabs for individual projects in the Project Manager Portal. 

84. (63798, 63799) WCAG – The buttons at the bottom of the Available Documents in the 
Documents tab for individual projects in the Project Manager Portal are configured as an 
unordered list, and the section contains a hidden title. 

85. (63818) WCAG - The links under the Rates Snapshot for individual projects in the Project 
Manager Portal are configured as an unordered list. 

86. (63819, 63869, 63870) WCAG – Pagination links for contract tasks as well as Provider counts and 
Provider details are configured as an unordered list. 

87. (63800, 63810, 63834, 63857) WCAG – Icons and buttons within individual projects in the 
Project Manager Portal are keyboard accessible. 

88. (63802) WCAG – A hidden title has been added to the details section in the Documents tab for 
individual projects in the Project Manager Portal. 

89. (63803, 69762) WCAG – The breadcrumb for individual projects in the Project Manager Portal 
has been corrected. 

90. (63725, 63820, 63851, 63853, 63854, 63863, 63871) WCAG – The colour contrast has been 
modified for improved readability on a variety of pages. 

91. (63874, 63876, 63877, 63879, 63880, 63881, 63882, 63884, 63943) WCAG – The Provider 
Scheduling pages in the Project Manager Portal have been rebuilt for improved WCAG 
compliance. 

92. (63825, 63828, 63831, 63833, 63836, 63837, 63838) WCAG – The individual project Contracts 
page in the Project Manager Portal has been rebuilt for improved WCAG compliance. 
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93. (63841, 63845, 63846, 63850, 63855, 63858, 63860) WCAG – The individual project Quotes page 
in the Project Manager Portal has been rebuilt for improved WCAG compliance. 

94. (63816, 63817) WCAG – The individual project Rates are properly formatted to improve 
readability by assistive technologies. 

95. (63720, 63731, 63811, 63821) WCAG – alt text has been added to links to improve readability by 
assistive technologies. 

96. (63808, 63809, 63819, 63830, 63844, 63856, 63868, 63872, 63878) WCAG – Additional headers 
have been added to improve readability by assistive technologies.  

97. (63719, 63723) WCAG – The focus order and visibility has been improved in the header of the 
Project Manager Portal. 

98. (63779, 63795, 63807, 63815, 63827, 64848, 63849) WCAG – Explicit labels have been added to 
form controls to improve readability by assistive technologies. 

99. (63914, 63915, 63916, 63918) WCAG – Project instructions are surrounded by <p /> tags for 
better readability. 

100. (63920, 63921) WCAG – Provider instructions are surrounded by <p /> tags for better 
readability. 

101. (63862, 63908) WCAG – The page to create a new project from the Project Manager 
Portal has been titled, and the response when no contacts are found labelled as a paragraph. 

102. (63873, 63883, 63909, 63910) The Providers pages in the Project Manager Portal have 
been titled. 

103. (63724, 63726, 63729, 63732, 63812, 63822, 63859, 63902, 63903, 63904, 63905, 
63906, 63907) WCAG – The project pages for individual projects in the Project Manager Portal 
have been titled. 

104. (63823, 63864, 63936, 63937, 63938, 63939, 63940, 63941, 63942) WCAG – A variety of 
minor issues in underlying page structures have been corrected in the Project Manager Portal. 

105. (73650) The obsolete setting List Profile has been removed from Settings > System 
Parameters > PCFs. 

106. (74372) The obsolete IIF export has been removed from Settings > Plugins > QuickBooks. 

107. (63294) Some French localization in the Customer Portal Advanced Search has been 
updated. 

108. (64546) Date formats are localized in the Customer Portal. 

109. (63366) The French localization of Delivery Date in the Customer Portal has been 
updated. 

110. (63348) The French capitalization for languages in My Flow > Communication in and 
Interface in has been updated. 

111. (63344) Additional spacing has been added to the French in My Flow > User Minimum 
Password Length. 
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112. (61090, 63365) Some localization in the Invoices section of the Project Manager Portal 
has been updated. 

113. (74691) Localization has been added in all languages to the Contracts and Invoices 
section of the Administration. 

114. (63355) The French localization for Project State has been updated in the Provider 
Portal. 

115. (63421) The French capitalization for My Contracts has been updated in the Provider 
Portal. 

116. (63292) A variety of French localization has been updated throughout MultiTrans. 

117. (75247) French and Spanish messaging has been updated when a Project Manager does 
not have permission to open a specific project. 

118. (75894) The English messaging when setting Customer Review tasks in a workflow has 
been corrected. 

119. (75880, 76524) Access rights for Providers have been localized into Spanish. 

120. (73743, 73839, 73923, 76533) Layout and spacing issues have been corrected in the 
Customer Portal. 

121. (73894, 73895, 73956, 74622, 75504, 76039) Layout and spacing issues have been 
corrected in the Project Manager Portal. 

122. (73987, 74062, 74074, 74078, 74081, 74089, 74093, 74129, 74137, 74142, 74643, 
74887, 75147, 75148, 75276, 75704, 75711, 75713, 75714, 76572) Localization has been 
updated in the new SSRS-based reporting module. 

123. (74096, 74177, 74124, 74141, 74291, 75169) Layout issues have been corrected in the 
new SSRS-based reporting module. 

124. (73995, 74070, 74085) The report displays are more consistent regardless of the user 
interface language. 

125. (74792) Unnecessary error messages have been removed from the logs for easier 
troubleshooting. 
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About RWS 

RWS Holdings plc is the world’s leading provider of technology-enabled language, content management and intellectual property services.  
We help our customers to connect with and bring new ideas to people globally by communicating business critical content at scale and  
enabling the protection and realization of their innovations. 

Our vision is to help organizations interact effectively with people anywhere in the world by solving their language, content and market  
access challenges through our collective global intelligence, deep expertise and smart technology. 

Customers include 90 of the globe’s top 100 brands, the top 10 pharmaceutical companies and approximately half of the top 20 patent filers  
worldwide. Our client base spans Europe, Asia Pacific, and North and South America across the technology, pharmaceutical, medical, legal,  
chemical, automotive, government and telecommunications sectors, which we serve from offices across five continents. 

Founded in 1958, RWS is headquartered in the UK and publicly listed on AIM, the London Stock Exchange regulated market (RWS.L). 

For further information, please visit: www.rws.com 
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*RWS Group shall mean RWS Holdings PLC for and on behalf of its affiliates and subsidiaries. 
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