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HOW TO FIX CORRUPT MULTITRANS XLIFF FILES

This is not an official document and is intended for support purposes only. This document assumes basic familiarity with XML syntax.

Recommended Tools

Notepad++ https://notepad-plus-plus.org/downloads/
e Once installed, also install the “XML Tools” plug-in via Plugins > Plugins Admin... (https://npp-user-manual.org/docs/plugins/#install-using-plugins-admin)

Liquid Studio (Free Community Edition) https://www.liquid-technologies.com/trial-download
e This software is not necessary but it will speed up the troubleshooting process.

Terminology used in this document

e Element - refers to an XML element. That is, everything between (and including) the opening and closing tag.

e Close off — add a closing tag after a corresponding opening tag.

e Segment & trans-unit — used somewhat interchangeably in this document, but strictly speaking a trans-unit (short for translation unit) encompasses both the
source text (source segment) and the target translation (target segment).

¢ Inline formatting — formatting (font size, emphasis, colour etc.) that is applied only to a specific selection of text.

Overview of the MultiTrans XLIFF schema

The MultiTrans XLIFF schema is approximately based on the OASIS Standard XLIFF 1.2 specification. The original OASIS specification can be found here:
http://docs.oasis-open.org/xliff/v1.2/os/xliff-core.html
While the MultiTrans XLIFF schema is slightly different, this specification can still be used as a reference to familiarise yourself with the overall file structure. Custom

elements and attributes specific to MultiTrans are typically prefixed with mc:



https://notepad-plus-plus.org/downloads/
https://npp-user-manual.org/docs/plugins/#install-using-plugins-admin
https://www.liquid-technologies.com/trial-download
http://docs.oasis-open.org/xliff/v1.2/os/xliff-core.html
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The overall structure of a typical MultiTrans XLIFF file looks like this:

version="1.0" encoding="utf-8"

Bonjour
Hello

To summarise each part of this structure:

e Each XLIFF file has exactly one root <xliff> element.

e There may be one or many <file> elements containing one <header> and one <body> element. There will only be more than one <file> element if the XLIFF file was
created using the “MultiTrans Merge” Flow Machine Task.

o The <header> contains an <mc:skeleton> element which is used when re-constructing the document back into its native format.

e The <body> contains one or many <group> elements.

e Each <group> element contains one or more <trans-unit> elements.

e Each <trans-unit> must contain exactly one <source> and one <target> element. The source and target contains the text from the original source document and its
translation to the target language. These may contain just plain text, but often there will be additional tags to specify various formatting or layout options.
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Trans-units in more detail

Aside from the mandatory <source> and <target> elements, a <trans-unit> may also contain many <alt-trans> (short for “alternative translation”) elements which are used
to track the changes made to each segment. Here is a simplified example:

extype="DOCX" id="57"

xml:space="preserve">Please translate this sentence.

state="translated" xml:space="preserve">Veuillez traduire cette phrase.
alttranstype="previous-version" origin="1"
xml:space="preserve">Please translate this sentence.
xml:space="preserve“>Veuillez traduire ceci.

:name="Created by" mc:type="STRING">Alice
:name="Created date" mc:type="DATE">20210101T090000Z
:name="Modified by" mc:type="STRING">Alice
:name="Modified date" mc:type="DATE">20210101T103000Z

In this example there is one <alt-trans> element which contains its own <source> and <target> elements. Note that the alttranstype="previous-version” attribute indicates
that this is a previous version of this trans-unit.

Other things to note about this example are:

e The <mc:props> element contains metadata about this particular trans-unit, such as who last modified it and when.
e There can be many <alt-trans> elements within the same <trans-unit>, each with their own child <source> and <target> elements, but there must only ever be one
<source> and one <target> that is a direct child of the <trans-unit> element.
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Here’s an example where there is extra formatting information applied to the text in the segment:

xml:space="preserve"

ctype="bold" id="65" mc:smlformat="Biu">Click here to search for information:
ctype="1link" id="b66" rid="r66" w:hyperlink r:id="rId7" w:history="1"

ctype="bold underlined x-mc-char-color x-mc-char-kern" id="67" mc:smlformat="BiU">https://duckduckgo.com
id="e66" rid="r66" xml:ctype="link" /w:hyperlink

state="translated" xml:space="preserve"
Cliquez ici pour rechercher des informations:
ctype="1link" id="b66" rid="r66" w:hyperlink r:id="rId7" w:history="1"
https://duckduckgo.com/?kad=fr_FR
id="e66" rid="r66" xml:ctype="link" /w:hyperlink

The <g> element is a common tag used to apply inline formatting to the text that it surrounds. In the above example, the text that comes before the hyperlink has bold

formatting applied to it (ctype="bold”) in the source element, but there is no formatting applied to the equivalent translation in the target segment because there are no
surrounding <g> tags.

Wherever there is a <bpt> element, there will also be a corresponding <ept> element somewhere after it. BPT and EPT stand for Begin Paired Tag and End Paired Tag
respectively and they are used to provide native code that the source format will understand. In the example above, these tags are used to provide <hyperlink> tags which
surround the URL in the text. When the target Word document is exported, these hyperlink tags are used to display the text https://duckduckgo.com/?kad=fr FR as a
clickable link in Microsoft Word.
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How to set up Liquid Studio for troubleshooting

When you first open Liquid Studio, go to Tools > Options > Editors > Large File Editor then change the A single line is longer than setting to the maximum value (8096KB). If
an XLIFF file is opened in the Large File Editor, you cannot use the validation features, so changing this option prevents this from happening:

Options
4 Editors ) The Large File Editor can edit files of any size (> 1TB) but has a limited feature set. You
Default Settings should decrease this value if you experience performance issues opening very large files.
Cs5
DTD Open documents in Large File Editor if:
b JSON 4 The file is larger than 75 [+] MB (Defautt 75MB, Max 150ME)
b JSON Schema —
Large File Editor A single line is longer than 8096 5 h KB (Default 256KB, Max B8096KE)
Text ———
b WSDL Large File Editor Settings
\
' 'tf[’l'-z Wirap ines longerthan 1024 2] Chars (Defaut 1024)
xHtm
b AML Defautt Encoding Unicode (UTF-8) ~
b XQuery
b XSD Max data on clipboard 4 % MB (Default 10MB, Max 2047MB)
KELT ) ;
b Environment File locking Read/Write Lock (other programs can not acce
Fort Size 10 =
Show non printable characters  []
Use stand in forts

oK Cancel

Go to File > Open > File... and browse to the corrupt XLIFF file. Once open, go to Edit > Advanced > Format Document to make the XML more readable:

Eile | Edit @ Wiew Tools Window Help

| '? P¢@ ¢ w00 EHl
B ) .Net 4.0 (XSD 1.0 aware) -
B cu Ctrl+X Ca
¥ ™ copy Ctri+C
Find| — — e -+ 1 | StartPage 4
IE X Delete Del <Find In 1 E<?xml ver:
L. 2 .
. SM+pkVv/pi
3
End v Find and Replace © ramesamnr
|: Go To.. Ctrl+G > 6 T+EpYcP3:
Look RGMTSFRET
C;E Ecolmarts i’ - =RNYLA¥qT!
- oyjnyPLEyi
HA__owinng > el et
Advanced * [ Format Document  Ctrl+K, Ctrl+D

Find Next E



To set up validation, go to Tools > Schema used to validate XML

Tools  Window Help

RY L Diff
1&p Convert DTD To XSD
,g“ Convert Fast Infoset To XML
Convert JSOMN To XML
Convert JSOM Schema To X5D
Convert XML To Fast Infoset

g9 9 04 g4 04

Convert XML To JSON
Convert XSD To JSOMN Schema

External Tools 4
Macros 4
Build XPath Expression

¥ validate Document F7
Schema Used to Validate XML Ctri+F7
£, Infer XSD Schema

In the list of XML Schemas, scroll down to the OASIS XML Localisation Interchange File Format (XLIFF) TC — Version 1.2 option and deselect it:

XML Document to XML Schema Mappings

The selected XML Schemas will be used to validate your XML document and provide intelisense.

L 0DASI5 XML Localisation Interchange File Format (XLIFF) TC - Version 1.2
[ Office Open XML (DOXML / OpenXML / Ecma 376) - Version 2006

m] ‘* OFX - Open Financial Exchange - Version 2.1.1

[m] ‘* 0GC Web Feature Service - Version 2.0
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Select the Add Schema File button and browse to the xliff-core-1_2-transitional.xsd XML schema file. You should then see the schema file listed under Additional Schemas
at the top of the list:

XML Document to X chema Mappings

The selected XML Schemas will be used to validate your XML document and provide intelisense.

| wiff-core-1_24ransitional xsd

4 ‘* XML Schema Standards Library

[W] 4 Acord - Life, Annuity Health Standards Program - Version 2.20.01

=] ‘* Acord - Property Casualty,/Surety Standards Program - Version 1.16.0

(m] ‘* Acord - Reinsurance _Large Commercial Standards Program - Veersion 2008-1
4% AdsML - Version 3.5 R3
AdsML - Version 3.0 R5
Ag¥ML - Agriculture Information - Version 2.0
Atom Syndication Format - Version 2005
Business To Manufacturing Markup Language - Version w0401
CDF Markup Language (CODFML) - Version 1.1
CDF Markup Language (COFML) - Version 3.5
(W] 4% CDF Markup Language (CDFML) - Version 3.7 A v

() o) o o] ]
FkEEEF

XML Schema Standards XML Schema Files
Add Standard Add Schema File
Reset Standards Library Close

Close this window and you'll see validation errors appear in the Error List at the bottom of the screen. Double click an error to go to the corresponding line in the file:

U72BD3THgREVCDaayEdici e IMDMIEE SarBT+1RXdd £ 02 1LIDBggHaSYYRY 92 gpohubRy 2y SUGTEUnkgRIANEDXE X(

7 E <mC:Iprops>

8 <mc:prop el ESilsl] ;f_gas\}<fmc:prcp>

9 <mc:prop m Even (CUQ/5DT)</mc:p:
10 <mC:prop m 0T170800Z</mc:prop>
] : m . . . i T { :

1 me:prop | The XML document is not valid and contains errors, 203v}"2v§§vﬂvl?"2’<x’mc BEel
12 </mc:props> :

13 <mc:target-pro

14 <mc:prop m M</mc:prop>

15 <mc:prop m [203T1336072</mc:prog
16 </mc:target-pr{

17 </header>

18 #fi— <bodv>

E Split Source Processing Instruction »

Error List
Code Location  Description
@ 1414:26  The element target' in namespace 'urn:oasis:names:texliffdocument1.2' has invalid child element 'alttrans' in namespace
possible elements expected: 'g, bpt, ept. ph. it. mrk, x, bx, ex'in namespace 'urn:oasis:names:texliffdocument1.2'.
@ 143318 The element 'group’ in namespace 'urn:oasis:names:texliffdocument1.2' has invalid child element 'group' in namespace 'u

possible elements expected: 'trans-unit, bin-unit' in namespace 'urn:oasis:names:texliffdocument1.2".
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Once you’re done fixing an XLIFF file in Liquid Studio, you will need to remove the extra whitespace created by using the Format Document option. See step 5 of the next
section below for instructions on how to do this using Notepad++.

Overview of how to fix files without Liquid Studio (using just Notepad++)

If for some reason you are unable to use Liquid Studio, here is how you can use Notepad++ to fix an XLIFF file:

1. Open the corrupt XLIFF file in the MultiTrans XLIFF Editor and make a note of the error that appears:

Error occurred while opening file

Details...

System.Exception: <trans-unit id="2:120": <target> element can contain only <g>, <x./>, <bx/=f A
<en/ss, <hpts, <epts, <pha, <it>, «mrk> elements; found <alt4ranss |

at MuliCorpora :)O'rff:ModeI:Xl'rf'fTransLlni‘t..ctor{)ﬂnlﬂeader reader, IXIi‘H Filelnfo doclnfa)
&t MutiComora XIiff Model Xiff Document read Trans UnitNode(Xml Reader reader, Strina path) ¥

s

falld

2. Open the XLIFF file in Notepad++ then select Plugins > XML Tools > Pretty Print (or press Ctrl+Alt+Shift+B) to make the XML more readable:

Plugins  Window ?

Opening file <B177-201117-1_131194_532494_ENG.xIf>...

| MIME Tools > [#]

] Converter ¥

1 >
NepExport 920 (https://www.liquid—technologies.com) ——><xliff
NppSaveAsAdmin P aek—version="20 smlns="urn:oasis:names:te:xliFF-doon
HML Tools > Enable XML syntax auto-check
Plugins Admin... Check XML syntax now

Open Plugins Folder... Enable auto-validation

1L AMEAUUUWY | T IDUDDUYSNE ] L Validate now Ctrl+Alt+Shift+M
Fv/ /LIxfQ2ZuWTouKEefARoY
yBQBTIDDOPLFIMDVOWwk+2ut . 13d auto-close
©hGMZ310ygCUCeMNGFINQYGs o sat XML type automatically
nOLBODAVEE+zss6pvvPm3SUy
v

/7 2O . It Prevent XXE .
m62+yo]gw/ 3ZvvHMIOVACKck Allow huge files
ROKxqglUlmidgam5)r6KTGB6E T pramy print Ctrl+Alt+Shift+8
010W2Meod/BtIFfDewIRzRO1 [(}n ;

Pretty print tindent attributes) Ctrl+Alt+Shift+A

A+ E2NAvaRaNFfuknaSEOS HEoF

The example message from step 1 contains <trans-unit id="2:120"> which refers to the <trans-unit> element with an ID of 120 that is the 2" <trans-unit> element

within its parent <group> element. To find this faulty <trans-unit> element, press Ctrl+F in Notepad++ and search for id="120":



<group> "
<trans-unit extype="DOCK" id="116"> [

<source xml:space="preserve" mc Fnd Rephce Findin Files Mark

w:val=&quot;003665&quot;/&gt; &
<target state="translated" zml:.
<alt-trans alttranstype="previo
<source xml:space="preserve
w:val=&quot;003665&quot ; /&g
</source>
<target state="translated"
</alt-trans>
<mc:props>
<mc:prop mc:name="Created b
<mc:prop mc:name="Modified ]

<mc:prop mc:name="Modified

oo on

<mc:prop mc:nams="Created d
</mc:props>

</trans-unit>

£trans unit extype="DOCK" i1d="120"F
<source xml:space="preserve" mc

Find what :| id="120"] w | | Find Mext
Count
[J1n selection Find Al in Current
Document
Backward direction Find Allin All Opened
[ match whole word anly Documents
[ match case Close
M Wrap around
Search Mode [ Transparency
O Normal ® 0On losing focus
O Extended (\n, \r, \t, \0, \x...) O Always
@ Reqular expression 1. matches newline ]
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Fix the problem with this <trans-unit>, save the file then open it again in the MultiTrans XLIFF Editor. Repeat steps 1 and 3 until the XLIFF opens without any issues.
Once the XLIFF file has no errors, make sure to select Plugins > XML Tools > Linearize XML (or press Ctrl+Alt+Shift+L) to remove the extra whitespace:

Plugins  Window ?

[ MIME Tools > [#] 3
Converter >
MNppExport ]
NppSaveAsAdmin b
XML Tools > Enable XML syntax auto-check
Plugins Admin... Check XML syntax now

| Open Plugins Folder...
ErvVe” U clveE T LULAac—0 Validate now
,'/&gt,' &lt;w:sz w:val=é&c

~ Tag auto-close

Enable auto-validation

ed" xml:space="preserve' o saf XML type automatically

~  Prevent XXE

£ype="STRING"> Allow huge files
e="STRING Pretty print

ied date" mc:type="DATE"
ed date" mc:typse="STRINC

ed by" mc:

ied by" mc:

Linearize XML

Pretty print (indent attributes)

Apply to all o&n files



Common Errors

Missing or misplaced closing tags
The following error messages typically indicate that an XML element has not been closed properly:
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The element ‘target’ in namespace ‘urn:oasis:names:tc:xliff:document:1.2’ has invalid child element ‘alt-trans’...
The element ‘group’ in namespace ‘urn:oasis:names:tc:xliff:document:1.2’ has invalid child element ‘group’...

The example below shows how to fix both of these errors. The key is to make sure that closing tags are where they should be:

Start Page
14d0
14a7
1488
1449
141@
1411
1412
1413
1414
1415
1416
1417
1418
1419
1428
1421
1422

S E Il BROKEN FAQ Je fact...xdf*

</Trans-unitx>
<trans-unit extype="gg£§" id="486">
<source xml:space="preserve"»<g ctype="bold" i1d="474" mc:gyézggﬂv;_"Blu">Let op</g
</sourcex
<target state="translated" xzml:space="preserve" m
Attention : si wotre<g ctype="x-mc-char-format

ngghalne facture ou prochain décompte est gélé en préparation SQEE nous,

s fo
id="727" mc:native-format-tag=

</g>

<alt-trans alttranstype="previous-versicn" origin="2" mc: da‘e_":£££$$ki$}£S§N3
<gource xml:space="preserve" mc:format="0-5:Bold///"><g ctype="bold" id="4
</source>

<target state="translated" =zml:space="preserve" mc:format="0-9:£f000000;10

Attention : Si votre<g ctype="
</target>

</alt-trans>

x-mc-char-format" id="727" mc:native-for

<alt-trans alttranstype="previous—versien" origin="1" mc:dat
—n

<gource xml:space="preserve" mc:format="0-5:Bold///" Y::trcﬂs,a):cncata—”l

</source>»

<target state="translated" xml:space="preserve" mc:format="0-120:£££ff00££f"
</alt-trans><mc:props> T—
name="Created by" mc:type="STRING">.
"Created date" mc:type="DATE">. c:prop>
"Modified by" mc:type="STRING"
<mc:prop mc:n. "Modified date"™ mc:type="DATE" mc:prop>

’°P - <,’target> in wrong place
{;"r rans—uni
T No closing </group> tag before next <group>

Pns-unit extype="DOCX" id="485">

<mc:

<mc:
<mc:

at="0-9:££000000;10-11:£££ff

1487
1498
1489
1410
1411
1412
1413
1414
1415
1416
1417
1418
1419
1428
1421
1422
1423
1424

-] <trans-unit extype—"DOLX" id="4Ba">

= <scurce xml:space="preserve"><g ctype="beld" 1d="474" mc:smlformat="Biu">Let op</g

</source>

= <target state="translated" xml:space="preserve" mc:format="0-89:££000000;10-11: fffﬂ

= Attention : si votre<g ctype="

prochaine facture ou prochain décompte est N;l; en EfEEEEEEJEE chez nous,
</g>

</tazget> ] arget closed off correctly

= <alt-trans alttranstype="

x-mc-char—-format" id="727" mc:native-— f:r"a.*_c =

previous-version" origin="2" mc:date="20201204T120016:;
i

= <source xml:space="preserve" mc:format="0-5:Bcld///"><g ctype="bold" i

</zource>
= <target state="translated" xml:space="preserve" mc:format="0-9:££000000;10-
Attention : Si wotre<g ctype="x-mc—char-format" id="727" mc:native-forr
</target>
</alt-trans>
= <alt-trans alttranstyp
= <gource xml:space=
</ source>
<target state="translated"” xml:space="preserwve" xc:format=“0—123:EEEEQEE;T
= </alt-trans»<mc: prcps>

previous-versicn" origin="1" mc:dat _“"62ﬁ1233T13340Z

reserve” mc:format="0-5:Beld///" transla _Egﬁata—“l

<mc: " mc:type="STRIN
<mc: Created date" mc:type="DAT /mc: prop>
<mc: Modified by" mc:type="S5TRI >

me: name="Modified date" mc:type="DATI /mc:prop>

</ncicg Erroneous </target> tag removed

</trans-unit>

<fgroup><—Group closed off correctly
—| <grcup>
= <trans-unit extvoe="DOCKX" id="495">



Duplicate / Erroneous <g> inline formatting tags

<g> elements can be long and contain several attributes, so you may wish to enable Word Wrap when dealing with these. In Liquid Studio this is done via Tools > Options >
Editors > Default Settings > Word Wrap (important: turn this off when finished, otherwise you may struggle to open subsequent files if they’re particularly large). In
Notepad++ this is done via View > Word Wrap.

Here are a few simple tips to keep in mind when correcting <g> elements:

e They should not contain other XML elements, including other <g> tags.

e They should also only appear within a <source> or <target> element.

e They can be self-closing (i.e. <g /> rather than <g></g>).

e The <alt-trans> elements containing previous translations will typically remain correctly formatted, so you can usually use their corresponding <source> and
<target> elements as a reference to see roughly how the main <source> and <target> segments should be formatted.

Example 1 — A self-closing <g> element erroneously placed outside of a <target> element. In this case, it can either be deleted or moved before the closing </target> tag:

372 <target state="translated" xzml:space="preserve" mc:format="0-84:££f000000">5elon nous, ce segment recéle encore du potentiel au-dela de la
crise de la Covid-18. </target>

373 g ctype="x-mc-char-format" id="201" mc:native-format-tag="&lt;w:shd wival=squot;clearsquot; w:color=&quot;autosquot; |
E:fil'_=&quct,FE‘FFE‘F&quet;/&qt;" mc:sml format="biu" /)I

Example 2 — A typical problem where an opening <g> tag is placed where there should be a closing </g> tag, causing multiple other issues.

Start Page - X

1e44 </source>

1845 [= = :zmace="praserya" mc::f::nr:.’.at="0—59:ffﬂOEGOU"}Formatted tEXt ShOUId come after <bpt> tag -

=
1846 <g ctype="underlined x-mc-char-colcr" id="486" mc:native-format-tag="&lt;w:color w:val=&quot;'30m_m:; &:E; &_:;w:szl

wival=squot;28aquot;/egt;" mc:smlformat="biU">

1047 Ccrporate bond=s and government bonds (including state bonds

g ctype="bold" id="8852" ”"'W—"Blu >‘$ EI'I'OI'IeOI.IS <g> tag

1848 B4E5" ri rfborelt;w:hyperlink w:anchor="_bockmarkd" w:history="1"agt; </bpt>

1849 < cty:a_— underlined x-mc-char-ceolor™ id="486" mc:native-format-tag="slt;wicolor wival=iquot;00RDEE&quot; fegt; eltiwisz
wival=squot;28equot;/egt; " ne:sulformat="biU" /> <) ﬂpllcate <9> element where text should be

1858 <ept ctype="link" id="e485" rid="r485"»>:clt;/w:h rlinkagt;<

1051 </5> < Erroneous </g> tag & missing </target> tag

1852 [= <alt-trans alttranstype=" prev:l.ous vers:l_o'm origin="3" mc:date="20201125T2128292" mc:user="GLOWO01\UI8665">

1853 [ <source xml:space="preserve" mc:format="0-62:Underline">

1854 <bpt ctype="link" id="p483" rid="r485">clt;w:hyperlink w:anchor="_bookmark3" wihistory="1"szgt;</bpt>

1855 <g ctype="underlined x-mc—char-color" id="486" mc:natiwve-format-tag="&lt;w:color w:val=squot;00ADEE&aquot;/sgt; &lt;wisz
wival=squot;28&quot;/&gt; " mc:smlformat="biU">Bedrijfscbligaties en overheidsobligaties (inclusief staatsbon) </g>

1056 <ept ct ype—“m“e485“ rid="r485">alt; /w:hyperlinkegt;</ept> T

1857 Fources

1858 | <target state="needs-review-translaticn" xml:space="preserve"
me: format="0-57: ££008000;58-60: ££000000;€61-61:££008000;62-64:££000000; 65-65:££008000"> correCt StrUCture

1859 <bpt ctype="link" id="p485" rid="r485">&lt;w:hyperlink w:anchor="_bookmark3" w:history="1"&cgt;</bpt>

1068 <g ctype="underlined x-mc-char-color"” id="486" mc:native-format-tag="&lt;w:color wi:wval=iquot; 00RADEE&quot; /&gt; elb;w:sz
wival=squot;28&quot;/&gt; " mc: m_“biU‘BCorpora:e bonds and government bonds (including state bond///s///)</g>

1061 <ept ctype="link" id="g485" rid="r485">&lt;/w:hyperlinksgt;</ept>

1062 </target>

1863 </alt-trans>



‘body’ start tag does not match the end tag of ‘file’

This likely means that there is a closing </body> tag missing before a closing </file> tag, as in this example:

998 </mc:props>

291 </trans-unit>

952 </group> >
993 </file3|

god | </xliff>

991
992
9493
994
9495

</trans-unit>
</ group>
<fbcdyﬂ
</file>
</xliff>

<alt-trans> should have at least one <target> element.
The segment history of a segment is missing a <source> or <target> element. For example, this <alt-trans> element only contains a <source> element and the <target>

element is missing:

<alt-trans alttranstype="previous-version" origin="1" mc:user="SYSTEM">

<source xml:space="preserve" />
<!-- No target element! -->

</alt-trans>
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