TRADOS quits unexpectedly / Setup did not complete

I have two problems:

When working in Trados (Studio 2021), Trados kicks me out of the program every now and then. As long as this is now and then, it is workable. However, this weekend I am experiencing this problem more and more, to such an extent that Trados quit immediately after I had opened it.

Most cases, there is no error message. Trados just takes very long to get on to the next segment and then quits. I only once had an error message:

 [error message: De instructie op 0x0000000077B03C41 verwijst naar geheugen op 0x0000000D954B81. Het geheugen kan niet worden gelezen. Klik op OK als u het programma wilt beëindigen

I am working in a document that exists of lots of shortish documents, varying from 1 word to approx. 500 words. At first error 2 occurred at the same position in the same document all the time. I then opened the set of documents without this one document. For some time, everything seemed to be okay. But the problem recurred more and more often. I tried working in one document at the time. This worked for a while and then the problems began again. In the end Trados quit immediately after I had opened it.

As I still wanted to finish my assignment, I decided to remove and reinstall Trados. That’s when problem 2 started:

Due to this error I could not remove or repair Trados.

 [error message: Setup did not complete. The error is: Setup has detected a different version of this product already installed. If you still wish to remove or repair that version, you must use that version's installer.]

I decided to install a trial version of Trados 2022. This worked fine, but immediately from the beginning I was kicked out of the package at the same point as described before. Again I opened fewer documents, which went fine for a while. Again the problem occurred more and more often. I have now managed all files but 5. For those files Trados quits almost immediately after I had opened them.

Can you please help me to get Trados working again?