qualitivity app installation problem / Studio cannot load afterwards

Hi everyone,

Our IT has tried to install the qualitivity app on our 2019 and 2021 license professional Studio versions some days ago. We work on virtual workplaces.

After integrating the plugin, Studio fails to load and we receive the following error message:

<SDLErrorDetails time="13.05.2022 11:17:47">
  <ErrorMessage>Failed to initialize view 'QualitivityViewController'.</ErrorMessage>
  <Exception>
    <Type>Sdl.Desktop.Platform.StudioException, Sdl.Desktop.Platform, Version=16.0.0.0, Culture=neutral, PublicKeyToken=c28cdb26c445c888</Type>
    <HelpLink />
    <Source>Sdl.Desktop.Platform</Source>
    <HResult>-2146233088</HResult>
    <StackTrace><![CDATA[   at Sdl.Desktop.Platform.Implementation.StudioWindow.EnsureViewSite(IViewReference viewReference)
   at Sdl.Desktop.Platform.Implementation.StudioWindow.GetController(String viewId)
   at Sdl.Desktop.IntegrationApi.Internal.ExtensionBuilders.AbstractViewControllerBuilder.Build(IExtension extension, Object defaultInstance, ExtensionArguments arguments)
   at Sdl.Core.PluginFramework.Integration.ExtensionsRepository.AddExtension[TResult](IExtension extension, ExtensionArguments arguments, Func`4 instanceCreator)
   at Sdl.Core.PluginFramework.Integration.ExtensionBuilderFactory.Build[TResult](IExtension extension, ExtensionArguments arguments, Boolean useCache)
   at Sdl.Core.PluginFramework.Integration.ExtensionBuilderFactory.<>c__DisplayClass4_0`2.<Build>b__0(IExtension extension)
   at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveNext()
   at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
   at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
   at Sdl.Core.PluginFramework.Integration.ExtensionBuilderFactory.Build[TAttribute,TResult](ExtensionArguments arguments, Boolean useCache)
   at Sdl.Core.PluginFramework.Integration.ExtensionsFactory.Create[TAttribute,TResult](ExtensionArguments arguments, Boolean useCache)
   at Sdl.Desktop.Platform.Implementation.ViewRegistry.InitializeIntegrationControllers()
   at Sdl.Desktop.Platform.Implementation.ViewRegistryOperator.InitializeIntegrationControllers()
   at Sdl.Desktop.Platform.Implementation.StudioWindow.Init(IEventAggregator eventAggregator)
   at Sdl.Desktop.Platform.Implementation.Studio.CreateWindowInternal(Boolean setActive, IEventAggregator eventAggregator)
   at Sdl.Desktop.Platform.Implementation.Studio.Run(ISplashScreen splashScreen, IEventAggregator eventAggregator, IPluginLoaderService pluginLoaderService, ICommandLineParsingService commandLineParsingService)
   at Sdl.TranslationStudio.Application.Launcher.RunApplication()]]></StackTrace>
    <InnerException>
      <Type>System.Data.SQLite.SQLiteException, System.Data.SQLite, Version=1.0.111.0, Culture=neutral, PublicKeyToken=db937bc2d44ff139</Type>
      <ResultCode>CantOpen</ResultCode>
      <ErrorCode>14</ErrorCode>
      <HelpLink />
      <Source>System.Data.SQLite</Source>
      <HResult>-2147481601</HResult>
      <StackTrace><![CDATA[   at System.Data.SQLite.SQLite3.Open(String strFilename, String vfsName, SQLiteConnectionFlags connectionFlags, SQLiteOpenFlagsEnum openFlags, Int32 maxPoolSize, Boolean usePool)
   at System.Data.SQLite.SQLiteConnection.Open()
   at Sdl.Community.TM.Database.Query.InitializeSettings(String databasePath, List`1 viewSettings, List`1 backupSettings, List`1 generalSettings, List`1 trackerSettings)
   at Sdl.Community.Qualitivity.Panels.Main.QualitivityViewController.Initialize(IViewContext context)
   at Sdl.Desktop.IntegrationApi.AbstractViewController.Sdl.Desktop.IntegrationApi.Internal.IViewController.Initialize(IViewContext context)
   at Sdl.Desktop.IntegrationApi.Internal.Adaptors.InternalDockingViewAdaptor.OnInit(IViewSite site, ISettingsGroup settings)
   at Sdl.Desktop.Platform.AbstractView.Init(IViewSite site, ISettingsGroup settings)
   at Sdl.Desktop.Platform.Implementation.StudioWindow.EnsureViewSite(IViewReference viewReference)]]></StackTrace>
    </InnerException>
  </Exception>
  <Environment>
    <ProductName>SDL Trados Studio</ProductName>
    <ProductVersion>Studio16</ProductVersion>
    <EntryAssemblyFileVersion>16.1.8.4404</EntryAssemblyFileVersion>
    <OperatingSystem>Microsoft Windows Server 2019 Standard</OperatingSystem>
    <ServicePack>NULL</ServicePack>
    <OperatingSystemLanguage>1033</OperatingSystemLanguage>
    <CodePage>1252</CodePage>
    <LoggedOnUser>SEWO\U436010</LoggedOnUser>
    <DotNetFrameWork>4.0.30319.42000</DotNetFrameWork>
    <ComputerName>SVDA0055</ComputerName>
    <ConnectedToNetwork>True</ConnectedToNetwork>
    <PhysicalMemory>66972192 MB</PhysicalMemory>
  </Environment>
</SDLErrorDetails>

What do we need to do to get the app working in our environment?

I think that someone has posted a solution to this issue, but that post seems not to be available anymore.

Thanks in advance for your help.

Kind regards,
Marion

emoji