References to an older version of the API assemblies after plugin migration from Studio 2019 to Studio 2022

Dear All,

I've started recently migration of our plugins from Studio 2019 to Studio 2022. To do that I follow the instructions given here:  How to update plugins to Studio 2021 

After the process plugin compiles and builds, but during launching Studio 2022 I see the warning pop-up saying Sdl.TranslationStudioAutomation.IntegrationApi and Sdl.Desktop.IntegrationApi are in version and the newer version of API installed.

Plugin does not load and does not exists in Studio. Please find below references from *.csproj to libraries.

Am I missing something? Is it a bug in Studio 2022?

  • Hi  , please make reference to the latest documenation to understand 'How to update plugins to Trados Studio 2022'

    Given the screenshot you attached above, I would also recommend the following:

    1. Replace 'C:\Program Files (x86)\' with the MSbuild property '$(MSBuildProgramFiles32)'
    2. Remove any non-required metadata from the Trados Studio assembly reference declarations (e.g. Version, SpecificVersion, Culture, PublicKeyToken etc...)
      <Reference Include="Sdl.Desktop.IntegrationApi">
        <HintPath>$(MSBuildProgramFiles32)\Trados\Trados Studio\Studio17\Sdl.Desktop.IntegrationApi.dll</HintPath>
      <Reference Include="Sdl.TranslationStudioAutomation.IntegrationApi">
          <HintPath>$(MSBuildProgramFiles32)\Trados\Trados Studio\Studio17\Sdl.TranslationStudioAutomation.IntegrationApi.dll</HintPath>

    It might be that you have some redundant plugin / unpacked that might be provoking this issue?
    Please check and clean up any unused or redundant plugins from these locations:

    Trados Studio 2019, 2021
    StudioVersion: 15, 16

    c:\Users\[USERNAME]\AppData\Roaming\SDL\SDL Trados Studio\[StudioVersion]\Plugins\Packages\
    c:\Users\[USERNAME]\AppData\Roaming\SDL\SDL Trados Studio\[StudioVersion]\Plugins\Unpacked\

    c:\Users\[USERNAME]\AppData\Local\SDL\SDL Trados Studio\[StudioVersion]\Plugins\Packages\
    c:\Users\[USERNAME]\AppData\Local\SDL\SDL Trados Studio\[StudioVersion]\Plugins\Unpacked\

    c:\ProgramData\SDL\SDL Trados Studio\[StudioVersion]\Plugins\Packages\
    c:\ProgramData\SDL\SDL Trados Studio\[StudioVersion]\Plugins\Unpacked\

    Trados Studio 2022

    c:\Users\[USERNAME]\AppData\Roaming\Trados\Trados Studio\17\Plugins\Packages\
    c:\Users\[USERNAME]\AppData\Roaming\Trados\Trados Studio\17\Plugins\Unpacked\

    c:\Users\[USERNAME]\AppData\Local\Trados\Trados Studio\17\Plugins\Packages\
    c:\Users\[USERNAME]\AppData\Local\Trados\Trados Studio\17\Plugins\Unpacked\

    c:\ProgramData\Trados\Trados Studio\17\Plugins\Packages\
    c:\ProgramData\Trados\Trados Studio\17\Plugins\Unpacked\

    try this and let me know how it goes

  • Hello Patrick,

    Thank you for your reply.

    I did as you suggested:

    - I cleaned all folders where plugins could be installed for 2015 and 2022

    - I changed references from 'C:\Program Files (x86)\' with the MSbuild property '$(MSBuildProgramFiles32)'

    and unfortunately no sucess, still

    We have 14 different plugins and only this one with references to *.IntegrationApi causes problems...

  • Hi , sorry to hear you are still have issues with this.  It's def pulling in the reference from somewhere...

    So to recap. You confirm the following

    1. You have followed the steps listed here: 'How to update plugins to Trados Studio 2022'
    2. As a test, you removed all plugins (incl. unpacked) for Trados Studio 2022, from the locations that I listed above.
    3. The HintPath's to Trados references in your project file are mapped to the folder '$(MSBuildProgramFiles32)\Trados\Trados Studio\Studio17\...'
      Note: I would also remove any non-required metadata from the Trados Studio assembly reference declarations (e.g. Version, SpecificVersion, Culture, PublicKeyToken etc...); make reference again to my example above.
    4. You compiled your plugin and still receive the same message when loading Trados Studio 2022.
      Note: the plugin is built in this folder: c:\Users\[USERNAME]\AppData\Roaming\Trados\Trados Studio\17\Plugins\Packages\

    What I would check next

    - Ensure you don't have 'Reference Paths' saved in the project (.csproj.user) settings, that will override the HintPath's in the project file. 

    1. Right click on the project and select Properties.
    2. Select the Reference Paths
    3. Confirm you don't have a Reference Path / Folder saved here that is mapped to the installation folder of an earlier release of Trados Studio

    - Check that you are using the correct PluginFramework releases for Trados Studio 2022

    1. Confirm that you have referenced the nuget packages in the project
      <PackageReference Include="Sdl.Core.PluginFramework">
      <PackageReference Include="Sdl.Core.PluginFramework.Build">
    2. Confirm you don't have a misselanous reference to an earler release in your project file (or packages.config...)

    - Ensure the Trados Studio instllation has not been compromized; run a repair on the installation.

    1. Load the Progam and Features system window.  (Window+R>Appwiz.cpl)
    2. Select Trados Studio 2022 from the list.
    3. Select the button Change>Repair

    - Is your project saved in a public repository somewhere, so that I can do a quick review?

  • Hi Patrick,

    Unfortunately, it's still the same.

    I checked all your remarks from above, I even launched plugin on different machine. The same error.

    We do not have any public repositories as we work for Public sector.

    If it's possible I can send you the Project by email?

    Best regards,


  • Hi , It might make sense if I take a quick peek at the project to try understand what is causing this; please send me the link to download it 

    Note: don't include a zip in the e-mail, instead upload it somwhere that I can download it from (e.g. oneDrive, dropbox etc...);

  • Hi  , the issue is derived from dependencies of the dependency DGTRAD.UI.  You'll need to rebuild that assembly first against Trados Studio 2022 assemblies + net48; everything else looks good; awesome work; clever solution(y)

  • Hi Patrick,

    Ahhh you have right!

    Old version of UI library (which is used in this project) has references to Sdl API.

    We missed it Disappointed

    Thank you for your help!

    Kind regards,