Constantly being asked to login when using Cloud Terminology in Trados Studio

Hello everyone,

When using a termbase stored in the cloud inTrados Studio, I am constantly asked to log in – even if I have done so very recently – whenever I am trying to add a new term to it.

Also, after clicking "Add New Term" and being asked to log in, the Termbase Viewer window defaults to the main page of the termbase, and the "Add New Term" action is not triggered. This means I have to go back to the segment and either use the shortcut or right-menu option again to trigger it.

This also means that the "Quick Add New Term" option sometimes does not work, as if I am not logged in it does not let me know or prompts me to do so, and the term ends up not being added.

Is this a known issue? Is there a workaround or way of forcing it to stay logged in?

Thank you very much!


Clarification, misspelling
[edited by: Bianca Coggiola at 4:57 PM (GMT 0) on 10 Jan 2024]
  • Hi  

    This behavior is not how it is intended to work. If Trados Studio is installed correctly, with Administrator rights, and on your local hard drive, it creates some files, where it stores your credentials for re-use. So normally you would only insert your login once, and then Trados Studio should remember it. 

    If, however, you have any Windows settings, or anti-virus settings that delete temporary files created by Trados Studio, or Studio doesn't have Administrator rights to create the temporary files it needs, this issue might appear. Can you check with your IT department if there are any user limitations and try to Run as Administrator Trados Studio and see if the issue persists?

    Hope the suggestions help. 

    Thank you,