The Trados Studio integrated AppStore may be incurring some temporary problems. If you need to install an application please download and install it from the RWS AppStore at http://appstore.rws.com

Trados 2022 bug - active project is NOT the one you change settings for

I had this problem on one computer and thought this was just a strange one-time problem but now it happened on another machine, a different install (someone asked me "what is going on?"). Kind of hard to define but I'll try to explain. 

Let's say you have a list of projects in your "Projects" tab and one of them is active, which is denoted by bold typeface. For the sake of this example let us assume each project on the list has a different language pair.

The problem manifests itself by not being able to connect a TM with a language pair consistent with your active (opened) project language pair. Let us assume, for example, that you have a de_DE>en_GB file open in your editor. Now you go to your project settings and attempt to connect a de_DE>en_GB TM for this project. Trados 2022 won't let you do this claiming that this is a wrong language pair. When this happened to me, I went "what?", maybe I misclicked something? I tried again very carefully to make sure I click the right TM. Error pops -up again. I went "why?!" I did everything right! I don't have any screenshots at this time, but they would not really be helpful here. This bug is not possible to show on a screenshot as it pertains to a sequence of actions. I'll try to make a video when this happens again.

The point is that the project setting that you open are NOT for the active project you are working on but likely for some other project from your list (the one that is not highlighted in bold typeface - perhaps the one you worked on before?). In order to fix this, you need to close the file in Editor, change your active project (by double-clicking) to another project and then back to the one you were working on in the first place. When you click on project setting after doing this, the correct project setting for your active project will open and you will be able to connect the desired TM (de_DE>en_GB in my example).

This is all for the moment, I will add more info if and when this bug manifests itself again. Thank you!

emoji