Google MT worked once but not in the next project: "An item with the same key has already been added"


I am using Trados 2021 for a week now. Today I used the Google MT for the first time in my new Trados, through the MT Enhanced Trados Plugin. It worked fine.

Now I opened a new file for translation, I tried adding Google MT again tot "Translation Memory and Document settings", selecting Use -> MT Enhanced Trados Plugin" it shows me the dialogue screen, I choose "Google Translator" the key is automatically filled in, I click OK and I get the error message "An item with the same key has already been added".

I have even tried renewing my API key, but with the new key it's still not working.

What am I doing wrong?

  • Hi ,

    Thank you for the details.

     Please can you confirm the following:

    1. how did you install it? manually or via the integrated AppStore in Studio?
    2. what version of the apps you installed (if you know)?

    My guess is the problem will go away if you uninstall the plugin, but I have this running at the moment without a problem so it would be better to understand why this is occurring for you.

    So please make sure you check all these paths:

    c:\Users\[USERNAME]\AppData\Roaming\SDL\SDL Trados Studio\16\Plugins\Packages\
    c:\Users\[USERNAME]\AppData\Roaming\SDL\SDL Trados Studio\16\Plugins\Unpacked\

    c:\Users\[USERNAME]\AppData\Local\SDL\SDL Trados Studio\16\Plugins\Packages\
    c:\Users\[USERNAME]\AppData\Local\SDL\SDL Trados Studio\16\Plugins\Unpacked\

    c:\ProgramData\SDL\SDL Trados Studio\16\Plugins\Packages\
    c:\ProgramData\SDL\SDL Trados Studio\16\Plugins\Unpacked\

    Hope it helps?