xychange command does not report missing input trans tables

Hello.  While running xychange, I ran into something that puzzles me.  It may be a bug in the code but I wanted to run it by the group before opening up a ticket, just in case I’m missing something obvious.

When I run xychange using command “/opt/xyvision/xz/bin/xychange” and my job ticket is set to call the wrong Xychange Library, xychange does not work, as I would expect.  However, I still get this information in a log file for my job:

Pass 1, Transformation table: Table1
Transformed … bytes

Pass 2, Transformation table: Table2
Transformed … bytes

>>> Successful completion of XyChange <<<

But, if I manually run an Import command on the same DIV in PathFinder, I get this, which I consider correct:

Running Xychange
Pass 1, Transformation table: Table1
Transformation file ' Table1' does not exist
ERROR: Xychange failed

I know that the manual import is using “/opt/xyvision/xz/bin/import.pl”.

My question is why does running /opt/xyvision/xz/bin/xychange report success to my log file even though the transformations actually do fail?

Any feedback is appreciated.