Exceed Alternatives?

Running XPP 9.4.2

Looking into using an alternative X11 viewer. 

We have tried Putty X11 forwarding to VcXsrv also tried Xming.  Those two renders have response, and multi-window issues.

We have tried MobaXterm that is unusably slow.

We are looking at RealVNC viewer on windows 10, with a Solaris RealVNC server, ssh -Y to Linux XPP server.  This has acceptable response, but copy paste loses special characters like:  

  • —–“”‘’ •¾°{|€û

The copy of special characters fails from word docs or pdfs outside of the XPP division.

  • Hi John,

    We test and qualify XPP with OpenText Exceed as noted in the Platform Requirements documentation: 

    "Open Text Exceed 14 or later (64-bit) is required on PC clients (Windows PCs accessing the Linux Application Server). The added Secure Shell package is required with Linux 8 (and later)."

    Unofficially, we have used MobaXterm with good performance and functionality, I understand it is slow for you. You noted RealVNC has copy/paste problems. Is there some configuration that could be done to address that within RealVNC or with the clipboard manager?

  • There is nothing obvious in RealVNC documents, the special characters do appear to be a limitation in the documentation.  below is an example of copy from word to XPP

    Screenshot of a Word document with text 'DEPARTMENT OF INDUSTRIAL RELATIONS WORKERS' COMPENSATION APPEALS BOARD' and a section of special characters not displaying correctly.


    Generated Image Alt-Text
    [edited by: Trados AI at 3:20 PM (GMT 1) on 16 Apr 2024]
  • Hi John,

    I just want to chime in here as well. You do get what you pay for with Exceed. From our experience it's the "best" and most robust for working with XPP (and IMO has a lot more "features" than most other packages), and as such it's the only X/Server that is extensively tested and officially qualified with XPP. As far as all the "freebie" X/Server packages out there, as the expression goes "you get what you pay for". We don't have the time or resources to test against all of the X/Server packages out there and work on "problems" with XPP with those packages.

    That said, we in development recently did make some fixes/improvements to the internals of XPP (specifically the sdedit and xyview programs) to address some "limitations" that were affecting XPP working as it should have been - even with Exceed.

    While doing that, we also did a very quick analysis of some obvious things that were not working when using MobaXterm as an X/Server (just for "fun") and were able to also address a few of those things.

    These "improvements" were included in the recent XPP 9.7.0 release. Hot fixes are available for the XPP 9.6 (and maybe the now retired XPP 9.4) release. Please reference public Knowledge Article XPP: Soft Keys not mapping.

    With just some quick testing of XPP with MobaXterm (free version), I found that the following MobaXterm settings worked best, and one limitation that I could not work around:

    • Set 'Unix-compatible keyboard' setting to "unchecked" (aka off) on the Settings > X11 tab
    • From my testing it appeared that MobaXterm never sends any "events" for the Print key (whether 'Unix-compatible keyboard' was on or off), so that key will never work with XPP. I did not see a way to be able to "map" (or re-map) keys (and what "events" they send), like you can do with Exceed (because OOB Exceed does not provide a mapping for the Print key, but you can change that).
    • I think most of my other X11 settings were pretty much the MobaXterm defaults and I certainly did not do any extensive experimentation with changing settings, but these are some of the other settings as I had them on the X11 tab:
      • Automatically start X server at MobaXterm start up: on
      • Xorg version: MobaX
      • X11 server display mode: "Multiwindow mode"
      • Clipboard: enabled
      • X11 remote access: on-demand

    With those (and the default) MobaXterm settings, I was able to open a Session to a Linux system running XPP 9.7.0 (that has those "improvements" I mentioned) and with some very limited testing I found that PathFinder, Sdedit, XyView, and the other GUIs all appeared to be working fairly well.

    Note: Just To Make Sure It's Entirely Clear, Nothing I Have Said Changes The Fact That MobaXterm Is Not Officially Qualified Nor Is It Supported. PLEASE DO NOT OPEN SUPPORT CASES FOR MobaXterm PROBLEMS (OR ANY OTHER X/SERVER PRODUCTS OTHER THAN Exceed); THEY WILL NOT BE INVESTIGATED!

    We have tried MobaXterm that is unusably slow.

    Not sure why you had that problem. I tried using the latest "stable" version of free MobaXterm (today that is Personal Edition v23.6 Build 5186) installed on a Windows 2016 Server VM. I was in a Remote Desktop session to that VM. I then opened an SSH Session in MobaXterm to a Linux VM running the XPP 9.7.0 release. All of this on a single RWS corporate network, of course.

    In that SSH session I was able to run PathFinder (xzxplorer) and it opened instantaneously. From PathFinder I was able to run sdedit and xyview (and all other GUI programs), and all those GUI programs also opened instantaneously.

    So, I did not see any "unusably slow" behavior with MobaXterm. But your environment could be different than mine in so many ways ...

    Jonathan Dagresta
    RWS Group/
    XPP Development