Passolo 2018 installed on Windows 11 crashes on import/export

We've had to reinstall Passolo 2018 on new Windows 11 laptops. The same issue is happening for the whole team:

When we open an existing project and try to import or export an SDLXLIFF, Passolo crashes. This especially happens when we select the "SDLXLIFF" format from the list and click "Settings".

We have an IT tech who says that this DLL is crashing: Sdl.FileTypeSupport.Bilingual.SdlXliff.XmlSerializers.dll

We are using Passolo Collaboration Editiong 2018, v 

We have made sure that all system requirements were installed on each computer (i.e. .Net Frameworks)

Parents Reply Children
  • Hi Adrian,

    Thanks for the reply. We have already verified the requirements were installed. We have tried re-installing Passolo from scratch, and it didn't help anything. We haven't tried a Repair, but I wonder if that would be any better than reinstalling from scratch... We've heard that there might be compatibility issues with Passolo 2018, Windows 11, and .NET Framework 4.8.... have you heard anything about that?

  • I've tried to access the SDLXLIFF export settings on Windows 11 machine and I see no issues.

    We had an issue in the past like:
    Is Passolo 2018 compatible with Windows 11? It crashes creating and removing glossaries but the issue was different and caused by Visual C++ not being installed correctly.

    Maybe this would also help here. 

    If not, I would recommend logging a support case and adding the Event viewer logs there or even here.

  • This is the event viewer info we get from the Passolo crash:

    Faulting application name: psl.exe, version:, time stamp: 0x6143329f
    Faulting module name: clr.dll, version: 4.8.9232.0, time stamp: 0x65efb9c4
    Exception code: 0xc00000fd
    Fault offset: 0x004593aa
    Faulting process id: 0x0x50A4
    Faulting application start time: 0x0x1DAA1579C5686CE
    Faulting application path: C:\Program Files (x86)\SDL\SDL Passolo\SDL Passolo 2018\psl.exe
    Faulting module path: C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll
    Report Id: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
    Faulting package full name: 
    Faulting package-relative application ID: 
    - <Event xmlns="">">
    - <System>
      <Provider Name="Application Error" Guid="{xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}" /> 
      <TimeCreated SystemTime="2024-05-08T14:54:56.3036720Z" /> 
      <Correlation /> 
      <Execution ProcessID="11336" ThreadID="23736" /> 
      <Security UserID="S-1-12-1-2896233390-1083852996-1843357109-2723805941" /> 
    - <EventData>
      <Data Name="AppName">psl.exe</Data> 
      <Data Name="AppVersion"></Data> 
      <Data Name="AppTimeStamp">6143329f</Data> 
      <Data Name="ModuleName">clr.dll</Data> 
      <Data Name="ModuleVersion">4.8.9232.0</Data> 
      <Data Name="ModuleTimeStamp">65efb9c4</Data> 
      <Data Name="ExceptionCode">c00000fd</Data> 
      <Data Name="FaultingOffset">004593aa</Data> 
      <Data Name="ProcessId">0x50a4</Data> 
      <Data Name="ProcessCreationTime">0x1daa1579c5686ce</Data> 
      <Data Name="AppPath">C:\Program Files (x86)\SDL\SDL Passolo\SDL Passolo 2018\psl.exe</Data> 
      <Data Name="ModulePath">C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll</Data> 
      <Data Name="IntegratorReportId">xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx</Data> 
      <Data Name="PackageFullName" /> 
      <Data Name="PackageRelativeAppId" /> 
  • I'm afraid I don't see anything that could cause the issue from the Event viewer.

    have you tried to re-install the Visual C++ redistributable?

    Other thing that could cause the issue might be the antivirus or maybe user permissions. Maybe you can try to run Passolo as Administrator.

  • Hi Adrian,

    Thanks for the suggestions. We've tried all of them now, and nothing makes a difference.

    However, we've done more testing and found out some specifics of the behavior:

    1. If you open an existing project, and export any file format (i.e. a Passolo bundle) first, then when you click on the SDLXLIFF Settings or try to import an SDLXLIFF, Passolo does NOT crash. And as long as that Passolo session stays open, it will not crash anymore.

    2. For the next Passolo session (meaning, you have closed it and reopened it), you have to do the export step again before accessing SDLXLIFF Settings or Import, or it still crash.

    3. If you create a new project in Passolo, Passolo will also not crash during that same session.

    So it looks like something happens in the back-end for Passolo when it exports and when it creates a new project, that somehow fixes the crash error. But it only lasts for that session.

    We're wondering if there is some environmental variable that maybe needs to be set, or a registry key, etc.

    Hoping these extra details help spark some new ideas!

  • There is no clear root cause from this but I would recommend a reset of Passolo:

    Including the registry settings:

    • Backup the registry and then delete the key HKEY_CURRENT_USER\SOFTWARE\SDL\Passolo 2018

    These should set Passolo to default installation and hopefully will help with the issue.

  • Thank you so much! This fixed it for us -- Although my team did actually uninstall/reinstall Passolo too, we had uninstalled/reinstalled it before with no change. Resetting the path and registry key made the difference. Here is exactly what we did (in case it helps someone else):

    1. Uninstalled Passolo 2018.
    2. Renamed C:\Users\%USERNAME%\AppData\Roaming\SDL\Passolo 2018 to C:\Users\%USERNAME%\AppData\Roaming\SDL\Passolo 2018_old.
    3. Deleted the key HKEY_CURRENT_USER\SOFTWARE\SDL\Passolo 2018 in Registry.
    4. Restarted computer.
    5. Installed Passolo 2018