XML reader giving "Could not load file or assembly" error

I have recently installed XML reader plugin in Trados Studio 2021 but whenever we tried to convert an XML file it gives the error message "Could not load file or assembly" as per attached screenshot. I have tried different xml files but they all give the same error. Can you please let me know how we can fix this error? I have contacted Trados Studio support but they directed me to the XML reader app developers. Thanks

emoji
Parents
  • I think the best approach is to remove the plugin completely and reinstall from the integrated appstore. Please close Trados Studio, delete these files/folders:

    c:\Users\[USERNAME]\AppData\Roaming\SDL\SDL Trados Studio\16\Plugins\Packages\XML Reader.sdlplugin
    c:\Users\[USERNAME]\AppData\Roaming\SDL\SDL Trados Studio\16\Plugins\Unpacked\XML Reader\

    c:\Users\[USERNAME]\AppData\Local\SDL\SDL Trados Studio\16\Plugins\Packages\XML Reader.sdlplugin
    c:\Users\[USERNAME]\AppData\Local\SDL\SDL Trados Studio\16\Plugins\Unpacked\XML Reader\

    c:\ProgramData\SDL\SDL Trados Studio\16\Plugins\Packages\XML Reader.sdlplugin
    c:\ProgramData\SDL\SDL Trados Studio\16\Plugins\Unpacked\XML Reader\

    Now reinstall by downloading within the integrated AppStore in Trados Studio.

    emoji
  • Hi Paul, I followed your instructions. I deleted the instances of the XML Reader app and then installed it via the integrated App Store in Trados Studio. However, when I click Generate Excel in the XML reader app and select the folder for the Excels, I still get the exception stating that the sdl.projectapi.automatictasks.analysis.dll is missing. I checked the folder location and the DLL is definitely not there.

    Any ideas?

    Thanks

    Rob

    emoji
Reply Children