Studio 2021 + DeepL - Error

Hi all,

A colleague of mine installed Studio 2021 and wanted to add the DeepL plugin.

Her Studio version is 16.0.1.2917, and we just downloaded and installed the current plugin (version 5.8.17.1).

The error message is:

sdlerror-202097-9h41m40s.sdlerror.xml
<SDLErrorDetails time="07.09.2020 09:42:01">
  <ErrorMessage>Der Wert darf nicht NULL sein.
Parametername: source</ErrorMessage>
  <Exception>
    <Type>System.ArgumentNullException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089</Type>
    <ParamName>source</ParamName>
    <HelpLink />
    <Source>System.Core</Source>
    <HResult>-2147467261</HResult>
    <StackTrace><![CDATA[   bei System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source, Func`2 predicate)
   bei Sdl.Community.DeepLMTProvider.DeepLTranslationProviderConnecter.GetLanguage(CultureInfo culture, List`1 languageList)
   bei Sdl.Community.DeepLMTProvider.DeepLMtTranslationProvider.GetSupportedTargetLanguages(LanguagePair[] languagePairs)
   bei Sdl.Community.DeepLMTProvider.DeepLMtTranslationProviderWinFormsUI.Browse(IWin32Window owner, LanguagePair[] languagePairs, ITranslationProviderCredentialStore credentialStore)
   bei Sdl.TranslationStudio.Common.TranslationMemory.TranslationMemoriesControl.pluginContextMenuStripItem_Click(Object sender, EventArgs e)
   bei System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
   bei System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
   bei System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
   bei System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
   bei System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
   bei System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
   bei System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
   bei System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
   bei System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   bei System.Windows.Forms.Control.WndProc(Message& m)
   bei System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   bei System.Windows.Forms.ToolStrip.WndProc(Message& m)
   bei System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)]]></StackTrace>
  </Exception>
  <Environment>
    <ProductName>SDL Trados Studio</ProductName>
    <ProductVersion>Studio16</ProductVersion>
    <EntryAssemblyFileVersion>16.0.1.2917</EntryAssemblyFileVersion>
    <OperatingSystem>Microsoft Windows 10 Home</OperatingSystem>
    <ServicePack>NULL</ServicePack>
    <OperatingSystemLanguage>1031</OperatingSystemLanguage>
    <CodePage>1252</CodePage>
    <LoggedOnUser>BüroPC\Elke</LoggedOnUser>
    <DotNetFrameWork>4.0.30319.42000</DotNetFrameWork>
    <ComputerName>BÜROPC</ComputerName>
    <ConnectedToNetwork>True</ConnectedToNetwork>
    <PhysicalMemory>8277272 MB</PhysicalMemory>
  </Environment>
</SDLErrorDetails>

What could be wrong here?

Thanks for any help!

Best

Annette (from Manfred's account)

Top Replies

  • Interestingly just reported the same error in another thread for 2019.  For your user, who just installed 2021 I would guess the problem is related to there being no language pairs available in Studio yet (and we need to fix this if it's the case), but I didn't think that would be the problem for Thilo as he's an existing 2019 user.

    Please try adding your language pairs here (if there aren't any) and then try again:

  • Hi Former Member,

    Thanks so much for your quick answer! I tried with my own installation (my colleague is not in the office currently) and added the language pair in question (there was non as you had thought), but unfortunately to no avail.

    Since I was able to repro the problem here, I think it is systematic.

    Best

    Annette

  • Thanks Annette... we'll take a look at this problem today.  Seems odd that I don't have this problem so I don't think it is systemic, but clearly there is something going on that we need to address.

  • Greetings,

    Many thanks for this answer,

    I am currently experiencing the same problem, with a freshly installed Studio 2021. There was indeed no language pair in said window (surprisingly) so I added my usual ones. But to no avail.

    If this helps, these are the things I tried :

    - Adding a couple language pairs (EN-GB>FR, EN-US>FR and IT>FR) as said above. These are well supported by Deepl. Tried adding Deepl Translation Provider along with my TMs in my project properties. No luck.

    - Restarted Studio and tried adding again Deepl along with my TM.

    - Removing, restarting computer (and therefore Studio) than adding Deepl plugin (this time from the Appstore window built in Studio 2021)

    - Recreating my API key in my Deepl Pro account..

    None of these steps helped.

    As a Freelance Plus user, I have two activations, and I did not stumble upon this error a few days ago (28.08.20) when I installed Studio 2021 and this plugin on my other computer (laptop, similar environment : Windows 10 ed. 2004 up to date).

    I have a very similar error details message as the one posted by Manfred Altmann (of course except that my error reads as "La valeur ne peut pas être null, Nom du paramètre: Source" in French -my system language- and that the "environment" tags match my own computer environment).

    I may post my own error details should you judge it necessary, but mine is very similar.

    I'll stay tuned should you need more info.

    Thanks again,

    Gilles

  • Thanks

    We're investigating this at the moment.  I'll post back in here when we know more.

  • I'm having the same issue since yesterday on a fresh 2021 installation.
    Tried to solve it alone, but no luck with this one.

    btw. I just noticed that the problem is also present on my 2019 version.

  • Hi Hans, hi everyone,

    After a few investigations on my own, I tried reverting to the previous version of the Deepl plugin (version 5.8.16.0) and I am no longer experiencing this problem.

    The problem seems to come from the last version of the Deepl plugin (5.8.17.1), which could explain that you are facing the same problem with Studio 2019 with this plugin.

    Hope this helps,

    Thanks Paul for your kind reply and investigations, and best of luck

    Regards,

    Gilles

  • Thanks for your investigation.  I actually believe the problem is related to the API key provided by DeepL not supporting the use of the languages endpoint provided by DeepL in their AP documentation. The last update we released, among other things, changed the way we get the languages to avoid having to release new versions every time DeepL add a new language which is better for you, and for us.  They provided an endpoint we can use for this and it works with the API key they provided to us for developing the plugin.

    However, this morning (out of desperation because we could not reproduce this problem you are all having at all) I purchased a Pro subscription with DeepL so I went through the same process as you do.  With my new API key the integration fails and I get the same error as you.

    So, good that we now know where the problem is coming from.  We have reported this to DeepL and are awaiting their response.  I'm hopeful they will be able to resolve this at their end by allowing the keys to access the same endpoints available in their API.  If they can't then we will change the plugin again and release a new version.  We don't want to roll back because there are other important changes in this release that are needed by some users.

  • Hi Former Member and everyone,

    Thanks for your investigations. Is the previous version of the PlugIn (version 5.8.16.0) still available somewhere? The AppStore only has the most recent one.

    Best

    Annette