IMPORTANT MESSAGE: We are still experiencing some difficulties that will affect your ability work with the RWS AppStore. Our IT team is working to resolve this but for now you may not be able to download or upload apps through the RWS AppStore. We apologise for the inconvenience and will update the community when we have a resolution in place. In the meantime you can take advantage of the Private AppStore if you are using Trados Studio 2021 or 2022.

Input model - mandatory vs. non-mandatory

My input model contains three languages.
Every time I'm adding a new term, I am promted to fill in the term field for all languages otherwise the entry won't save. I usually add DE and RU first, while EN joins at a later point in time.

Is it possible to change the settings (definition or input model?) so that the entry is saved without me having to fill in all three languages or deleting the ones I don't want?

Thank you very much in advance.

  • Hi,

    Perhaps you made these mandatory fields when you created the termbase?  So your options are either to change the definition using the Catalog View (2011)/ Termbase Management View (2014) or perhaps recreate your termbase with the fields you want.  The latter suggestion may be easier than it sounds if you have the Glossary Converter and your termbase structure is simple.  You can drag the sdltb file into the Glossary Converter which will create a spreadsheet.  remove the columns you don't want (so leave yourself with two languages perhaps) and then drag the spreadsheet back into the Converter to have the termbase recreated.

    The Glossary Converter is a free application you can get from here : Glossary Converter

    Regards

    Paul

  • Hi Paul,
    I have the same problem as 'kzharkov' (I work with MT 2017 SR1), but unfortunately your answer did not help.
    When I (re)create a termbase, whether from scratch or in any of the modalities the Termbase creation wizard offers, the field 'Term' always appears ticked as 'Mandatory' and 'Multiple' with no possibility to untick it. Mine is a 10 languages termbase, all active, which means that I may have a term for EN and DE, though not necessarily for ES, and if I add or edit an entry I am forced to fill all terms in all languages if I want to save the edited/new entry.
    How can I 'untick' the Mandatory option for the 'Term' field in the termbase definition when I recreate it? (I could send some screenshots if I knew how to attach them to this note)
    Anyway, thanks in advance
    Julián
  • I have almost the same problem. If I have an input model active, the target language term is mandatory. If I don't, it isn't. As far as I can see, the reason for this is that when you create an input model, the "Mandatory" box for each of the terms is ticked and greyed out, i.e. you can't untick it.

    My current workaround is to type a space in the TL term. MT then allows me to save. Not very elegant, but it works.

    emoji