Replacing "\n" in an Excel file with a tag - Trados 2019

I have an Excel file where soft returns are coded as text (\n). I want to convert them to tags to get them out of my way. They often appear after segment-ending punctuation (period, exclamation point, question mark) without a space between the two, resulting in segments that can contain multiple sentences.

Source text in Excel and resulting segment in the converted file: Blah blah blah.\nText text text.

I would like:

Segment 1: Blah blah blah.

Segment 2: [tag]Text text text.

or

Segment 1: Blah blah blah.[tag]

Segmeng2: Text text text.

Working on a primitive level, I have prepped the Excel files by adding a space (search for ".\n" replace with ". \n" (etc. for ? and !) to get the segmentation right, but I really would like tags instead of \n -- they're distracting and make spell checking laborious (every "nText" has to be dealt with).

It would be wonderful to replace them with a tag and get the segmentation to work the way I want it to. The solution seems to lie in defining a tag in Embedded Content in the Excel file type and possibly also a segmentation rule. "\\n" doesn't work for me, but my knowledge of regex is pretty limited so any number of things could be wrong or missing.

Does anyone know how to go about configuring this?

Thanks in advance!

emoji
Parents Reply
  • Thanks, I will try it again later today.

    One result I have observed is that by turning on Enable Embedded Content Processing, I do see conversion to tags of other coding when I reprocess the source file. So the default Regular Expression Start Tag <\?[\p{Ll}\p{Lu}]\w*[^<>]*> is being applied.

    The configuration I have currently:

    Default Placeholder, Regular Expression Start Tag <\?[\p{Ll}\p{Lu}]\w*[^<>]*> with Include With Text selected in Advanced Settings for Segmentation Hint.

    My unsuccessful Placeholder, Regular Expression Start Tag \\n with Exclude selected in Advanced Settings for Segmentation Hint

    emoji
Children