the translation interface can not prompt the content from the main translation memory

In my Trados translation project, there is a main translation memory (into which I have imported the content of the original text that will be translated via TMX) as well as a project translation memory (an empty translation memory).

Screenshot of Trados Studio showing two translation memories, one with content from TMX and one without content.

QUESTION 1. However, when I select both the main translation memory and the project translation memory, why doesn't the translation interface prompt the content from the translation memory (given that the content to be translated is exactly the same as that in the main translation memory)?

Screenshot of Trados Studio translation interface with no matches found, despite the sentence being in the main translation memory.

QUESTION 2. Why can't the Fragment Alignment status of the main translation memory be switched to the ON position either?

Screenshot of Trados Studio settings with the Fragment Alignment status toggle in grey color, indicating it cannot be set to 'on'.



Generated Image Alt-Text
[edited by: Trados AI at 1:34 PM (GMT 0) on 29 Feb 2024]
emoji
Parents
  • Hello,

    Based on your query, it seems like you're having trouble with the translation memory (TM) in your Trados Studio project. Let's try to address your concerns one by one.

    Question 1: The translation interface not prompting content from the main translation memory.

    This could be due to a few reasons:

    Step 1: Check the language pairs in your main TM and the project. They should match exactly for the TM to work properly.

    Step 2: Ensure that the main TM is updated and active in your project settings.

    Step 3: Check the settings of your TM. If the 'Penalize multiple translations' option is enabled, it might be causing the issue.

    Step 4: Make sure that the 'Search for 100% matches' option is enabled in your project settings.

    Question 2: The Fragment Alignment status of the main translation memory can't be switched to the ON position.

    This could be due to the following reasons:

    Step 1: Check if the 'Enable Fragment Alignment' option is enabled in your TM settings.

    Step 2: Ensure that the language pairs in your main TM and the project match exactly. Fragment alignment might not work if there's a mismatch.

    Step 3: Fragment alignment might not work if the segments in your TM are too short or too long. Check the segment lengths in your TM.

    Remember, it's always a good idea to keep your software updated to the latest version to ensure optimal performance. If the problem persists, you might want to consider creating a new project and importing your TMs again.

    I hope this helps! If you have any other questions, feel free to ask.

    Best regards,

    TradosAI

    emoji
  • Your answer is useless for the first question! You DID NOT solve the problem!

    emoji
  •   

    Your answer is useless for the first question! You DID NOT solve the problem!

    Instead of just complaining why don't you work with it and explain that you have checked all of these things.  Maybe also prove that the TMs you are using do indeed contain the translation and that the TM you are looking at is 100% the same TM in your project (check the paths etc.)

    The instructions for working with the AI are quite clear, just reject the answer and provide more clear information.  The AI cannot read your mind... it's just a computer!

    emoji
  • Dear Mr. Paul. 

    Thank you for your reply. 

    But I have checked my main translation memory and project translation memory for several times. 

    This is the proof of the  main translation memory

    Screenshot of Trados Studio interface showing a translation memory with English and Chinese text side by side.

    This is the proof of project  translation memory. 

    Error message in Trados Studio stating 'No translation units to display' in the translation memory search results.

    If we select both translation merory, The main translation memory will not indicate any sentence on the upper part. 

    Trados Studio project settings window with translation memory enabled but not displaying results.

    Trados Studio showing a red arrow pointing to an unchecked box next to a translation memory, indicating it is not active.

    If I only disable the project translation memory, the main translation memory will indicate the sentence unit in the main tranlation memory. 

    Trados Studio interface with a red arrow highlighting the 'Enabled' checkbox for a translation memory, which is unchecked.

    You can  check this by yourself. 

    We did not want to complain, and the phenomenon was met by many other people; However, they just do not want to bother to give the feedback. 

    We paid a lot of money to trados, and we have dealt with various bugs and errors and  problems of trados for years. 

    We really hope that trados team could be responsible for all the international clients and take time and widom and true true skills fix all the bugs and provide reliable trados for all the clients. 

    Best ragards. 

    Trados Clients

    emoji


    Generated Image Alt-Text
    [edited by: Trados AI at 1:34 PM (GMT 0) on 29 Feb 2024]
Reply
  • Dear Mr. Paul. 

    Thank you for your reply. 

    But I have checked my main translation memory and project translation memory for several times. 

    This is the proof of the  main translation memory

    Screenshot of Trados Studio interface showing a translation memory with English and Chinese text side by side.

    This is the proof of project  translation memory. 

    Error message in Trados Studio stating 'No translation units to display' in the translation memory search results.

    If we select both translation merory, The main translation memory will not indicate any sentence on the upper part. 

    Trados Studio project settings window with translation memory enabled but not displaying results.

    Trados Studio showing a red arrow pointing to an unchecked box next to a translation memory, indicating it is not active.

    If I only disable the project translation memory, the main translation memory will indicate the sentence unit in the main tranlation memory. 

    Trados Studio interface with a red arrow highlighting the 'Enabled' checkbox for a translation memory, which is unchecked.

    You can  check this by yourself. 

    We did not want to complain, and the phenomenon was met by many other people; However, they just do not want to bother to give the feedback. 

    We paid a lot of money to trados, and we have dealt with various bugs and errors and  problems of trados for years. 

    We really hope that trados team could be responsible for all the international clients and take time and widom and true true skills fix all the bugs and provide reliable trados for all the clients. 

    Best ragards. 

    Trados Clients

    emoji


    Generated Image Alt-Text
    [edited by: Trados AI at 1:34 PM (GMT 0) on 29 Feb 2024]
Children
  •  

    I don't believe there is bug here.  I do believe you are missing something in how you have gone about working with this project.  I created a short video to explain to you what to look out for and also why you have clearly omitted something in your process.  Take a look and see if this sheds some light on where you are going wrong:

    emoji
  • Dear Mr. Paul. 

    Thank you very much. We appreciate your valuable and timely help. 

    With the help of your detailed vedio explanation, I undertand the root of the problem. 

    I created  the blank main translation memory, and chosed "analyse only" from "batch tasks" in creating the project. Then I imported the TMX only to the main translation memory, so the project translation meory is still empty. 

    It seems that when will enable both main translation memory (with all the content for the current source text ) and project translation memory (without content; blank TM), trados will automatically only use the project memory and do not use the content in the main tranlation memory to suggest the match in the up-left part. 

    We will mannually populate the project tranlation again to let the content move from the main translation memory to project momery. However, we hope that trados can fix this problem in the future version. 

    Again, thank you for your pofessional help. You are very helpful. 

    Best wishes 

    Jack 

    emoji
  •   

    There isn’t anything to fix here. I wonder if you are misunderstanding the concept of  a Project Translation memory.

    It is designed to work by creating a memory that only contains matches based on your settings that are relevant to your source text.  So when you work, or send out a package for others, only the Project TM is used.

    The way you are working makes little sense in this context because there is almost no point in having it at all. You might as well just translate without a Project TM and then create a new TM at the end to update into… or convert the SDLXLIFF files into a TM.

    emoji