Having problems creating XML file type in WorldServer 11.7.3 from Trados Studio 2022



I recently got a new laptop and installed Trados Studio 2022. I needed to create a new XML file type for WorldServer Trados Studio only offers the following file types for creation:

Until now in Trados Studio 2021, we had always used the XML Embedded Content file type, but this is no longer available. So I chose XML 2 and created my file type. However, it could not be imported into WorldServer.

So I created a test file type and the rest of this post deals with that and shows what's happening.

(created as stated with the XML 2 file type)

Exported to .sdlftsettings file (attached to this post).

Tried to import into WorldServer:

So I checked the sdlftsettings file:

Then I take a closer look at the XML 2 file types allowed by WorldServer:

The only one that seems relevant to my situation would be XML 2: Any XML, but I am not able to change its setting or create a copy of it in Studio:

So my question is this:

How am I supposed to create an XML file filter in Trados Studio 2022 and successfully import it into WorldServer?

Converted TXT file to link (it needs to be renamed to .sldftsettings. Also added additional clarity.
[edited by: Michael Schroeder at 6:19 AM (GMT 0) on 14 Mar 2023]
Parents Reply
  • Hi Michael, sorry, there was a typo in my previous instructions: I entered, <SettingsGroup Id="XML: Any v">

    instead of 

    <SettingsGroup Id="XML v">

    Let me summarize the instructions:

    1- In Trados Studio, create your File Type configuration normally using File > Options > File Types > New from XML2.
    2- Export your File Type configuration to a *.sdlftssettings file
    3- Before importing it into WorldServer 11.7.x (which would lead to the error), open the .sdlftssettings file in *Notepad ++

    <SettingsGroup Id="Copy of XML v">
    and replace it with
    <SettingsGroup Id="XML v">

    <Setting Id="FileTypeConfiguration_ComponentBuilderId">XML v</Setting>
    and replace it with
    <Setting Id="FileTypeConfiguration_ComponentBuilderId">XML v</Setting>

    Note: <FileTypeDefinitionId> is optional, it does not really need to be changed.

    Save your change and import the File Type configuration again. The import will work. However: the filter configuration will not appear under the XML 2: Any XML File type, but under the Custom XML (Legacy Embedded Content) File Type.

    - To modify the XML2 File Type Setting file to a Custom XML (Embedded Content Processor) file type configuration, follow the same step above but use 

    <SettingsGroup Id="XML v">

    <Setting Id="FileTypeConfiguration_ComponentBuilderId">XML v</Setting>

    In my tests, the segmentation was fine after the import and exactly as in Studio. However, I have used a simple test source file and a simple configuration without embedded content processor(s) enabled.

    I also would like to let you know that the issue with the 0 words after segmentation does not happen on all 11.7.x environments when applying the previous workaround to the XML 2 File Type. While I can reproduce in one of my test environments, creating an XML 2 File Type and then replacing only

    <Setting Id="FileTypeConfiguration_ComponentBuilderId">XML v</Setting>


    <Setting Id="FileTypeConfiguration_ComponentBuilderId">XML: Any v</Setting>

    and importing it, in several other 11.7.x test environments, the segmentation works perfectly and matches the one in Studio. I am not sure yet what is different in your environment and in the one where I can reproduce. So far I could not find out. 

    I think that it would be great if you could submit a WorldServer support case so we can work on this together, exchanging files and having a call as this thread is getting too long and possibly for Community, I am afraid.