IMPORTANT MESSAGE: We are still experiencing some difficulties that will affect your ability work with the RWS AppStore. Our IT team is working to resolve this but for now you may not be able to download or upload apps through the RWS AppStore. We apologise for the inconvenience and will update the community when we have a resolution in place. In the meantime you can take advantage of the Private AppStore if you are using Trados Studio 2021 or 2022.

Problem with MT Enhanced PlugIn - The format of value '<null>' is invalid

Hi everyone,

we are currently trying to use the MT Enhanced Plugin together with Microsoft Translator. I can configure the plugin with no problems. The Translator Key from MS Translator also seems to be accepted. However, when trying to pre-populate segments with MT output, the following error message is shown: 

The format of value '<null>' is invalid.

I tried different files, but I always get this message. I am using Studio 2019 SR2 - and Version of the MT Enhanced Plugin.

Any help or advice on this would be much appreciated. 



  • I have just tested this in 2019 and it seems to work fine for me:

    I am using a more recent version of Trados Studio, but the plugin version is the same.  So I have:

    Trados Studio 2019 SR2 -

    Plugin is

    I'd like to rule out two things here:

    1. can you update to use the latest version for 2019?  Certainly we will not look at making any changes for an older version of Studio than this
    2. can you share a file that causes this for you?  I cannot reproduce this problem so I'd like to rule the content in the file out
  • Hi Paul,

    thanks a lot for looking into this. 

    Please find enclosed the two files I used for testing:



    As far as the Studio version is concerned, I will try to update my version and get back to you on this. 

    One more question: The location/region setting of our MS translator is set to "westeurope". May this be something that could cause this behavior? I read in some other thread that changing this setting to "global" could change the behavior of the plugin. 

    Best regards, 


  • Hi Frank,

    I was waiting to see if you updating would help.

    Anyway... I created a video with your files creating a project with pre-translation and into four target languages.  I have no problems as you can see so I think you either need to upgrade, or maybe the region does have something to do with this.  Have yo tried changing it?  Mine is set to North Europe but I don't really know what difference it makes and it's so long ago when I set this up I am definitely not an expert!