Shortcut CTRL+Z (undo) not working

The shortcut CTRL+Z stops working when I open multiple files in Studio 2019. Again. And again.

Although I've been told by the support, that this well known bug will finally be fixed with SR2 - after many, many years. I meet this bug since 2015.

Is there FINALLY a solution, how to remove this bug?


In the "old version" this bug could be temporarily fixed by copying a word into the concordance search field and providing the search. Then it worked again for while.

Now I have to close all open files and to open a single one again.

This is really annoying.

  • Many shortcuts have never worked in Studio, for many, many, many years now, This is kind of ridiculous for a company of this size with this much money. I've been asking for this one now for god knows how long:

  • This is very typical for SDL.

    This occasional shortcut bug is well known since years too.

    I have been promised by the support guys, that this problem will be finally solved with the release Studio 2019 SR2. After years.

    But, unfortunately, the bug is still here... Like many others.

  • Hi SDL, thank you for your "support".

    Two weeks passed and still no answer and no help. 

    Just great...

  • ,

    I'm afraid there is no good answer for this.  We are well aware of the problems with keyboard shortcuts but seem unable to fit the work in that is required to resolve it.  So I can't give you an answer that will be helpful in the short term at all... I wish I could.

    I know you think a company of this size should be able to sort this out but I'm afraid it is never as simple as that. I also know there is little point in me trying to explain to you why because it won't help, nor will it make any difference.  We are looking at ways in which we can resource this work specifically and focus more on the improvements that are needed to ensure Studio is more performant so things like this simply work as expected.

  • Former Member
    0 Former Member in reply to Paul

    I am not in the pay list of SDL but, this comment is one of a Good kind.
    Whatever its content, reply itself is important.
    I am hoping the positive one the next time.

  • 1. You have no good answer for this? Maybe you can explain, why I have been promised by SDL support a few months ago, that this problem will be solved with Studio 2019 SR2. Did not happen. Unfortunately, this problem is known since 4 or 5 years at least.

    2. UNDO is in my eyes somehow one of the basic functions of every editor. The last tool without UNDO I did ever use was a Czech text editor in 1995!!!

    3. Maybe you should recommend me, that I write an AHK script to solve this crap. Which did already happen once, that I have been recommended to solve YOUR problem by myself. This recommendation came with a funny ";-)" smiley...

  • I have tried to be honest with you because you do deserve a response.  But there is nothing I can do to change the current situation other than continue to represent these concerns with the product management teams.

    I also don't know what you expect to achieve by asking me to explain why something that was promised by Support wasn't delivered.  Clearly the support team were advised that the work was planned in, but then for one reason or another it didn't happen.  Not the fault of the support team, and probably not the fault of the development teams who planned to tackle this either.  If other work takes longer than expected, or something important is dropped into the schedule then something else gets dropped.  That's the reality.

    The fact some of these problems are many years old is not good, and the reason I'm trying to be honest with you is because we are entirely at fault and should have addressed this properly by now.  I can only support the need to get this done as a priority effort, gather the criticism from you in this forum and share it where I hope it will do the most good.

  • Thank you for your comprehensive answer.

    Let me now illustrate this case on another situation. Imagine you buy a car, a premium car like e.g. Audi or Mercedes - because SDL Studio is a premium product on the CAT market. You find out, the breaks are not working from the first moment on. What do you do now? You contact your repair service - because you have some warranty and you want to use it. And the repair service wants you

    1. To understand the organization structure of the car company

    2. To understand, that they (the car repair service) did not develop the breaks, it was the developer.

    3. To understand, that the developers are well-informed about the problem. That they also have promised to solve this problem, though, but now they are developing brakes for another car, so it is clear, that they do not have time to put right yours.

    4. An last but not least you should be aware of the fact, that you will be helped only if you pay aprox. 1/5 of the car price p.a. and buy a service contract. Otherwise the car warranty is related only to two problems - if you can not start or unlock the car.

    Do you understand my point? This is how SDL treats his customers.

  • ok 

    Please provide me with the exact steps to reproduce the Ctrl+Z not working and I will escalate this again to development.  I can conclude from your cryptic message at the start that you are running a search and replace in multiple files but I am unable to reproduce.

    I have put a short video here showing you what I am doing.  Perhaps this will help you to provide some proper instructions that I can follow to achieve the problem you are encountering with Ctrl+Z. Being able to reproduce a problem is an essential part of fixing it... I hope you can understand that?

    You also say this has been known for 4 or 5 years.  Please show me how you know this and where I can validate this?  Throw away comments based on heresay or complaints you have seen over the years in the forums doesn't mean anything.  We don't investgate every complaint in every public forum and enter them into our database.  Complaints could be completely unfounded, and many of them come from the same users over and over again... which like it or not points towards other problems and not necessarily only problems with Studio.

    I have just run a search in our database like this:

    Trados Studio search results showing two entries with no visible errors or warnings.

    You can see the query and I only get two results returned... neither of which seem to relate to what I'm guessing you are referring to.

    Please provide me with the steps to reproduce this and I will ensure there is a bug logged for this, I'll give you the bug number, and you can track that, and refer to it if we never fix it in the future.

    I can find 29 unresolved bugs related to keyboard shortcuts (two of these are the undo problems I shared above)... each one is reproducible and most only occur under very specific crcumstances.  There are some general issues that affect everyone and this is what I've been referring to when I talk about problems with keyboard shortcuts.

    But you are complaining about this very specific problem with Ctrl+Z.  So, I have been completely open with you and only ask that you provide some reproducible steps and we will investigate it.


    Generated Image Alt-Text
    [edited by: Trados AI at 1:36 PM (GMT 0) on 29 Feb 2024]
  • I have not written anything about search and replace here. I have complained that CTRL+Z is not working. At the same time, the UNDO function does not work. This happens not always but randomly when I open several files from various projects.
    It happened right now. I have changed something in the text (first screen shot) and you can see in the second screen shot, that the undo function is gray = not active. And the shortcut CTRL+Z does not work too. In this moment 2 files from 2 different projects are opened.

    Screenshot of Trados Studio with text highlighted and the undo function icon grayed out, indicating it is not active.

    Screenshot of Trados Studio's ribbon menu with the 'File' tab circled, showing no visible errors or warnings.

    That's the exact description of what I'm doing. I can not write more. I just open a second file to translate and the function randomly stops working. In the Studio 2019 SR1 in this case also e.g. CTRL+A, CTRL+F did not work. The bug could be fixed by running the Concordance Search. Then the function was restored. Now in SR2 nothing works, I have to close and to reopen the files or even to restart Studio.

    The problem I am reporting here has been reported to SDL Support several times in the past few years. The last time in April & July/August 2019.

    In April I got the following messages from SDL Support:

    Email excerpt from SDL Support acknowledging a defect with the undo function in Trados Studio and suggesting a workaround.Email excerpt from SDL Support assuring the defect with the undo function is known and will be fixed in future releases.

    And here you will find the promise I got in July/August 2019 from the SDL support in several mails regarding Case No. 00437446:

    Screenshot of a document stating that shortcut issues have been addressed in Trados Studio 2019 SR2.

    Screenshot of a document stating that features including CTRL+Z, CTRL+F, and CTRL+A are to be introduced in Trados Studio 2019 SR2.

    I have reported this very same problem repeatedly since 2015. 

    As you understand, I can not agree with your statement:

    But you are complaining about this very specific problem with Ctrl+Z.

    It is not a "very specific problem".

    This problem is very well known since a long time. And it is not only about the keyboard shortcut. It is about the UNDO function itself, which stops working too.


    Generated Image Alt-Text
    [edited by: Trados AI at 1:37 PM (GMT 0) on 29 Feb 2024]