Shortcut CTRL+Z (undo) not working

The shortcut CTRL+Z stops working when I open multiple files in Studio 2019. Again. And again.

Although I've been told by the support, that this well known bug will finally be fixed with SR2 - after many, many years. I meet this bug since 2015.

Is there FINALLY a solution, how to remove this bug?


In the "old version" this bug could be temporarily fixed by copying a word into the concordance search field and providing the search. Then it worked again for while.

Now I have to close all open files and to open a single one again.

This is really annoying.

  • Hi SDL, thank you for your "support".

    Two weeks passed and still no answer and no help. 

    Just great...

  • ,

    I'm afraid there is no good answer for this.  We are well aware of the problems with keyboard shortcuts but seem unable to fit the work in that is required to resolve it.  So I can't give you an answer that will be helpful in the short term at all... I wish I could.

    I know you think a company of this size should be able to sort this out but I'm afraid it is never as simple as that. I also know there is little point in me trying to explain to you why because it won't help, nor will it make any difference.  We are looking at ways in which we can resource this work specifically and focus more on the improvements that are needed to ensure Studio is more performant so things like this simply work as expected.

  • I have no idea what you are trying to undo.

    Usually people want to UNDO, what they have done. In an editor like SDL Studio it is e.g. writing, inserting tags, inserting TB entries etc. Just all the normal actions you do in an editor. All the actions, that should normally be undone with "UNDO".

    If you actually told me and gave me the steps I wouldn't have to guess!

    Don´t guess, just read. I wrote it clearly:

    In the "old version" this bug could be temporarily fixed by copying a word into the concordance search field and providing the search. Then it worked again for while.

    But as I say, this is already history. In the current version (SR2) I have to reopen the file or to restart Studio to fix the problem (for a while).

    You seem to have activated the Alt keys

    NO. Alt has been activated when I pushed "Alt+PrtScn" to make the screenshot. 

    But even if ALT were activated, the UNDO function (the button) would have to be active. As you can see here:

    Screenshot of Trados Studio interface highlighting inactive UNDO button in the toolbar, with red circles around the button and the 'Alt' key indicator.


    Generated Image Alt-Text
    [edited by: Trados AI at 1:37 PM (GMT 0) on 29 Feb 2024]
  • Come on Adrian... you should know by now that things are not this simple.  This is simply not enough:

    Usually people want to UNDO, what they have done. In an editor like SDL Studio it is e.g. writing, inserting tags, inserting TB entries etc. Just all the normal actions you do in an editor. All the actions, that should normally be undone with "UNDO".

    This is working fine for me.  So on this basis we'll never fix anything.  I don't see anyone else complaining about the undo the way you are and you are not helping me to narrow this down at all to some specific action, or interference, that might be triggerring this.  It could easily be caused by something you have running on your machine and we'll never be able to reproduce it.

    Try paying close attention to what you last did when the undo failed.  Perhaps there is something you just didn't notice before but actually helps you to reproduce the problem.

    You could also provide me with your Studio logs after this happens.  Maybe we'll get lucky and find something in  there.

  • Thanks for your honesty Paul.

    I think it might be a good idea for you guys at SDL to yourselves test which shortcuts are dead (and have been for years). Then, if you don't foresee being able to fix them in the short term (which I fully understand btw), please god: at least (temporarily) remove any mention of them in the UI and help docs, as it is extremely frustrating to keep running into things that just don't work. It's less depressing if the user isn't told about them to begin with, as you can't miss what you don't know. 

    All in all though, I must admit that I am using Studio more and more lately as it is very snappy (in general) when compared to e.g. memoQ, which (although an excellent tool) has just gotten too slow over the years. Scrolling through the grid in memoQ 9.2 makes me want to die screaming.


  • Hi Adrian,

    Thank you for your feedback regarding the Undo option.

    We would like to investigate this issue further, but as this could not reproduced each time, we need to have more details.

    It would be helpful if you could confirm the following:

    1. the version of Studio you are using, if you have the latest Cumulative Updates installed

    2. the actions you tried to complete before using the Undo

    3. if you notice this on specific file, projects, packages

    Thank you



  • Hi Sorina and Paul,

    I wrote a lengthy answer but received an error message after hitting Reply and lost all the work.. Apparently I had to "join" this group to be able to post replies, but it would be good not to discard the users' drafts when they try to post without joining the group – maybe even disable the "Reply" button in such case. But that's another story for another time.

    I had issues with undo while working through the workbook for the advanced certification for translators. Basically I just opened one file for translation (with the auto-created project), made changes in editor, then opened another file in the same way, made changes in the editor and undo remained disabled.

    Here is a video repro.

    The files used are the sample files from the aforementioned course (section 6 – folder is 06_FileTypes, files are Command.docx and Sample.idml)

    Can you please look into it?

  • I know it's a little late for feedback on that issue, and believe me, I am also very annoyed at the bugs that have added up in Trados versions over the years, but I actually found a workaround for that issue, based on your feedback that it happens randomly “when [you] open several files from various projects.” It also happened to me randomly when I had more than one project open. So I tried systematically closing all projects before opening another one, and I never got that issue again. 

    I know it's not an ideal solution, but as I said, it's a suitable workaround for me, until the issue is definitely resolved by SDL.

    And by the way, thanks to Paul Filkin for his honesty: I prefer being told the plain truth (that he unfortunately cannot do anything about it, but will continue pushing for a resolution), rather than being made empty promises.

    Edit: The issue does continue to happen once in a while even when I have only one single-file project open, but it it always resolved (at least for a few days) when I close all projects and reopen the one I need (even if it's the same one that was open).  

  • Hi Paul, 

    As I mentioned in another comment, I know it's probably too late for 's specific case, but since the problem still exists to this day, I will try providing some insights in case it would help find a cause.

    • The CTRL+Z issue does not seem to be linked to any specific operation. It just happens, sometimes, that you type a few words and press CTRL+Z and it just doesn't work. I don't specifically remember what I had done in the seconds to minutes before it happened, but my guess is that it may happen when Trados, or the project itself, has been open for some time. Maybe it's because Trados' memory becomes overloaded? Or maybe it can be linked with the computer being put in sleep mode and woken up in the meantime, while the Trados project has remained open? I Thing that would be worth investigating.

    • In any case, the CTRL+Z issue seems to be consistently solved (for an indefinite time, usually a few days) when we close all Trados projects. Then, we can reopen the project we were already working on, and the CTRL+Z works again. That is just a workaround, not a solution, but maybe knowing that could also help find an actual solution.

    • By the way, thanks a lot for trying to help as best you can, and for being honest when you don't see an immediate solution. I prefer a clear, but disappointing answer to a vague, optimistic promise that will lead nowhere. Keep up the good work!

  • Hi  !

    First, as always, let me tell you I really appreciate your honesty. It would be so easy to just beat around the bush with stereotyped cant, yet you state the situation plainly. Numerous users (including me) are dissatisfied with RWS technical support in many ways, but your honesty honours you personally and is greatly appreciated.

    Now, with the issue at hand: it is indeed a recurrent problem that CTRL+Z regularly stops working, and the only “common denominator” I could find is that it happens when multiple projects are open in the Editor. 

    It typically does not happen right away. It happens when there have been more than one file open in the Editor and you have continued working in one or more of the files.

    By experience, I'd say it WILL necessarily happen after some time, but it could take days... or just minutes. I know the recommended practice would be to restart the computer every day, but given that there are occasional network problems that make restarting Trados Studio impossible AND it tends to happen at the worst possible moment (Murphy's law), many of us in my organization prefer to keep it open for the whole week.

    Of course, restarting the program is a workaround, but the BIG problem is that you don't know when the CTRL+Z dysfunction will occur, and if it happens to occur when you made a major error and want to correct it, it may cost several minutes of work.

    Anyway, if you want to reproduce the issue, all you have to do is open, say, three or more different projects at the same time in the Editor, type and confirm segments for a while, switch project and do the same (without closing the other projects), then “rince and repeat” untill CTRL doesn't work. Unfortunately, I can't say how much time it could take, but it will almost certainly occur.

    Hope this helps, and thanks again for what you do as the communication channel between consumers and other RWS officials. 

  • Hi Guys! My experience has been that whenever I make an error, like hitting two keys by accident, that the CTRL+Z stops working. It has happened variously in single files and with multiple files, but I usually don't have more than one project open at one time, so that doesn't seem to be what is triggering the error. There really doesn't seem to be regularity to me. It's a big drag when you loose a whole segment you just worked on and have to reboot Studio all over in the middle of your concentration...Thanks for the input! Deborah

  • Paul, I'm happy to inform you that this bug persists in 2024 and I have been experiencing it for years without making a post about it.

    Your classic "works on my machine" responses are really aggravating. I understand you feel helpless but the sarcasm and gaslighting in your responses are totally unacceptable.

Reply Children
  • I think you misread what Paul has been explaining; I don't think he is being sarcastic or gaslighting, just being bluntly realistic (better that than hypocritically rosy) about the fact that without specific action and computer event cues, the technical team is unlikely to find the source of the problem.

    The CTRL+Z issue is undeniably a recurrent issue for many people. But what we still need to find out is how to trigger it consistently, so that the bug-correcting programmers can reproduce it easily in order to find the causes in software and possibly hardware conflicts, hence the following instruction that Paul gave to Adrian Palme 4 years ago:
    Text requesting attention to actions performed before undo failure in Trados Studio and suggesting to provide Studio logs for analysis.

    And also, this input from Sorina Cuibus is highly relevant:
    List of questions asking for confirmation of Trados Studio version, actions before using Undo, and if the issue occurs on specific files or projects.

    In my case, it seems to happen when I've been working on a project for a long time without closing it, and it's especially frequent when I open one or more additional projects without closing the one that was already open. But I haven't found a way to reproduce the issue consistently for troubleshooting purposes. And I'm working on a corporate computer which has some very specific security and administration-related settings which can also contribute to it.

    So, in short, the only way an actual solution could be found is for us all to collectively provide as much details as possible regarding when and how the issue occurs: in what environments, on which kind of computers, in association with what other software, after typing this or that combination of keys, with or without other projects open, whether the project is large or not, what plugins are used at the same time, etc.

    That is not gaslighting; that is light seeking. Slight smile


    Generated Image Alt-Text
    [edited by: Trados AI at 1:37 PM (GMT 0) on 29 Feb 2024]