Unable to install Plugins and/or unable to start SDL Plugin Management tool.
Symptoms:
- You are unable to start the SDL Plugin Management tool
and/or
- You have successfully downloaded a Plugin, but you are unable to start the installation by double-clicking the plugin.
Explanation:
The SDL Plugin Management utility is searching for a (Windows) common resource/dependency file that has been removed.
Root cause:
The most likely cause, is after uninstalling Studio, the process has not been completed correctly.
You can check this by going to Windows> Control Panel> Programs and Features
If, you can see the following incorrect file association...
…and/or where one or more of the following folders** has been deleted.
**This example, shows a PC that has Studio 2015/2017 and Studio 2019 installed
This will vary depending on which versions you have installed!**
This issue will also arise, if you have deleted the Studio folders without first uninstalling Studio correctly via the Windows Control Panel
Resolution:
(2015 and 2017 versions only)
Note the versions that have an incomplete file association (... Remove suite of products) and then scroll to the Studio version (2015 and 2017 only), Right click, and Repair
(2019 versions only)
Confirm Windows will make changes. Click repair.
The file association will now be restored.
Now reboot your Computer and restart Studio- You will now be able to start the SDL Plugin Management utility and install the Plugins
You will find the installed Plugins in the relevant Plugin folder
Should you have further questions or need support regarding SDL Plugins, please visit the SDL Community
https://community.sdl.com/product-groups/translationproductivity/f/openexchange_applications